Project

General

Profile

Emulator Issues #13043

The Legend of Spyro: A New Beginning's cutscene will briefly desync at certain timestamps

Added by lasers 8 days ago. Updated 7 days ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

The Legend of Spyro: A New Beginning

Game ID? (right click the game in the game list, Properties, Info tab)

G6SE7D

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

652a91ff450633d2e1fd2eb7bfdd3571 (Good dump)

What's the problem? Describe what went wrong.

This game uses lot of in-game animation cutscenes, but later at near end of the game, a video cutscene will be shown... This video cutscene will briefly desync at certain timestamps.

Video: https://transfer.sh/WHKGND/Screen%20Recording%202022-09-20%20at%204.32.27%20AM.mkv

What steps will reproduce the problem?

[Reproduction steps here]

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Unknown.

Is the issue present in the latest stable version?

Dolphin 5.0-17269

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

Na.

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

I attached few fifo files and screenshots to illustrate the issue at hand.

What are your PC specifications? (CPU, GPU, Operating System, more)

MacBook Air (M1, 2020)

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

I attached a gamesave too.

Spyro-G6SE7D.zip (984 KB) Spyro-G6SE7D.zip lasers, 09/20/2022 09:59 AM
mpv-shot0002.jpg (170 KB) mpv-shot0002.jpg lasers, 09/20/2022 10:18 AM
mpv-shot0001.jpg (182 KB) mpv-shot0001.jpg lasers, 09/20/2022 10:18 AM
mpv-shot0004.jpg (193 KB) mpv-shot0004.jpg lasers, 09/20/2022 10:18 AM
mpv-shot0003.jpg (117 KB) mpv-shot0003.jpg lasers, 09/20/2022 10:18 AM
mpv-shot0005.jpg (158 KB) mpv-shot0005.jpg lasers, 09/20/2022 10:18 AM
mpv-shot0006.jpg (157 KB) mpv-shot0006.jpg lasers, 09/20/2022 10:18 AM
mpv-shot0007.jpg (152 KB) mpv-shot0007.jpg lasers, 09/20/2022 10:18 AM
9246
9247
9248
9249
9250
9251
9252

History

#1 Updated by lasers 7 days ago

Changing Texture Cache Accuracy slider from Fast to Safe in Graphics settings will solve this issue on multiple pre-rendered cutscenes.

It may be useful to document this minor issue on the wiki. Here's the GameINI for game's user config too. Thank you.

[Video_Settings]
SafeTextureCacheColorSamples = 0

Also available in: Atom PDF