Project

General

Profile

Actions

Emulator Issues #13056

closed

Only one controller but recognized as different players

Added by Deguinho 2 months ago. Updated 2 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Hi,

I was starting to use dolphin, and got a mayflash dolphin bar along with a controller to start playing My Sims. The models are those :
https://www.amazon.co.uk/gp/product/B00HZWEB74/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1
https://www.amazon.co.uk/gp/product/B07NXZR2K4/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

Also, the rom I got was a .nkit, so there was a message saying this could cause some problem but I am not sure this is related. What is a rom for wii supposed to be ? .wii ?

It indeed recognized the controller easily and the sync went well, however I have come to realize that depending on what mode the bar was set on, the wiimote would have different lights showing where it is supposed to tell the player number. For example in mode 1, the wiimote is player 1 for a second and then gets on player 2. Because of that, it is impossible for me to play anything, even though the wiimote does work as pressing the home button does as if I pressed the windows button on my keyboard, and I can even use it on other applications like Chrome or TFT.

If I activate mode 2, the lights for player 1 and 4 light up, but this time, the home button does the same thing but I can't control anything in a rom either. I have tried My Sims and My Sims Kingdom.

If I activate mode 3, the player 1 does show up, but the wiimote controls don't do anything any more.

If I activate mode 4, the player 1 light shows, the wiimote vibrates once, the controls allow me to press A or + to start the game, but when I have to point to click the screen and create a new save file, I simply can't, the pointer doesn't move or anything, it doesn't even appear on screen...

Therefore, I have no idea what is going on, or how to solve this. I have tried to look up for answers but didn't find anything, that is why I am coming here for help.

Thank you in advance, and have a great day!

Actions #1

Updated by JosJuice 2 months ago

  • Status changed from New to Invalid

It seems to be acting as if you don't have a sensor bar (which is slightly unusual, seeing as you do have one). This kind of support query is best handled at the forums, since it's not about a bug in Dolphin.

Actions #2

Updated by Deguinho 2 months ago

I have found out the bug, and some people are talking on Reddit about it. It was all linked to Steam latest update that allowed Wiimote's use. Therefore as soon as I closed Steam, everything worked perfectly. Idk if you can do anything about that or if it is on their side, but there is the info if you didn't have it yet.
Thank you for your help,
Best regards

Actions

Also available in: Atom PDF