Project

General

Profile

Actions

Emulator Issues #13078

open

Manhunt 2 FMVs run 1 FPS/60 VPS at default Emulated CPU Clock, throw unknown opcodes in dualcore due to large FPS/VPS desync

Added by JMC4789 about 1 month ago. Updated about 1 month ago.

Status:
Fix pending
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Manhunt 2

Game ID? (right click the game in the game list, Properties, Info tab)

RHTE54

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

f8291f1fb37eb437d84e40cd5e1217a7

What's the problem? Describe what went wrong.

There's two different ways things can go.

Single Core

When booting the game, after the Wii Strap Screen, the game screeches to a halt. It will run ~1 FPS through the Rockstar logo video. If you skip the first FMV, the main menu and actual gameplay run at normal speed.

Dual Core

Same thing happens, but the FPS will bounce around from 0 to 30, to 60, to 24, etc. etc. and eventually lock up with an unknown opcode.

What steps will reproduce the problem?

Boot the game, changing between Single Core and Dual Core for the two behaviors.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-17713

Is the issue present in the latest stable version?

Yes

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

N/A

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

AMD 5950x, RTX 3060, Linux

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Increasing the Emulated CPU clock to around ~184% seems to rectify the issue but I'm not entirely sure how/why. This seems like an odd failure state.


Related issues

Has duplicate Emulator - Emulator Issues #12784: Manhunt 2 - Occasional Hang Before MenuDuplicate

Actions
Has duplicate Emulator - Emulator Issues #12783: Manhunt 2 - Slow Single Core SpeedDuplicate

Actions
Actions #1

Updated by JMC4789 about 1 month ago

Actions #2

Updated by JMC4789 about 1 month ago

Actions #3

Updated by JMC4789 about 1 month ago

Note this is a different behavior than the Alien Hominid FPS/VPS desync and the Ubisoft (007 Quantum of Solace) style of problem.

Actions #4

Updated by JMC4789 about 1 month ago

It turns out I jumped to a conclusion - any CPU clock above 100% completely resolves the issue. Even 103%.

Actions #5

Updated by JMC4789 about 1 month ago

  • Status changed from New to Fix pending

https://github.com/dolphin-emu/dolphin/pull/11213

This is a hack - the issue will be rolled into the CPU clock override megathread once fixed.

Actions

Also available in: Atom PDF