Project

General

Profile

Actions

Emulator Issues #13092

open

Can't map emulated wii remote with combining mouse keyboard and a xbox controller (Deb build)

Added by Levan 28 days ago. Updated 28 days ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

**Description

What's the problem? Describe what went wrong.**

I just simply can't combine xbox one controller and mouse and keyboarded like i used to now when i combine both sometimes some buttons work but others don't how can i fix this.
https://i.imgur.com/pgZ3U3V.png
The d pad works on the controller
But the analogs don't
https://i.imgur.com/m65KwWE.png
If i select xbox controller than the analog works but i can't map the mouse and keyboard especially mouse movements
https://i.imgur.com/dWmhFTF.png
I could map this but now i don't know what happened
Using latest dev builds before now i could see all devices in controllers but now they are gone (Updated today)
https://i.imgur.com/jK7JIHZ.png

**
What steps will reproduce the problem?**
Just use the latest dev build and try to set up all three together mouse keyboard and xbox controller - I'm using 5.0-17748
Branch: master
Revision: 0716fa3c52063c444d352f65a159da77b9ce9bd8

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.
5.0-17748

Is the issue present in the latest stable version?
Haven't tested

Actions #1

Updated by JMC4789 28 days ago

Right click the inputs and swap the device on them to the one you want to use. It looks like there's no device set on them, so they just use the default device which is keyboard/mouse.

Actions #2

Updated by JosJuice 28 days ago

  • Tracker changed from Issue to Emulator Issues
  • Project changed from Infrastructure to Emulator
  • Issue type set to Bug
  • Regression set to No
  • Relates to usability set to No
  • Relates to performance set to No
  • Easy set to No
  • Relates to maintainability set to No
  • Operating system N/A added
Actions #3

Updated by JosJuice 28 days ago

If you click the little arrow next to Refresh, you'll find the new location of the All Devices option.

Actions #4

Updated by Levan 28 days ago

JosJuice wrote:

If you click the little arrow next to Refresh, you'll find the new location of the All Devices option.

If i understand correctly this is what i should press under refresh but you can see that either mouse doesn't work or analog when trying to set up the buttons, neither do pressure buttons work.

https://imgur.com/a/Iiajs6n

Actions #5

Updated by Levan 28 days ago

I should add that on 10/10/2022 I downloaded the dev build and it had all devices but the mapping still didn't work as now

Actions #6

Updated by AdmiralCurtiss 28 days ago

This is a side-effect of us supporting multiple backends with the same devices, it looks like. ciface::MappingCommon::RemoveSpuriousTriggerCombinations(&detections); (MappingCommon.cpp line 52) removes the multiple detected axes.

Actions #7

Updated by AdmiralCurtiss 28 days ago

(you can work around this by using the advanced input window btw, just right-click the button and manually configure the desired axis)

Actions #8

Updated by Levan 28 days ago

advanced input window - did the track thank you

Actions

Also available in: Atom PDF