Project

General

Profile

Actions

Emulator Issues #13113

open

Audio is behind on Cubeb, lag even worse on WASAPI

Added by haleyhalcyon 3 days ago. Updated 2 days ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Rhythm Heaven Fever [JP], but issue occurs with any game

Game ID? (right click the game in the game list, Properties, Info tab)

SOMJ01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

3f4e542f936bce7353c60b0c2b960e91

What's the problem? Describe what went wrong.

I am trying to play Rhythm Heaven Fever, but the input-to-audio-response lag was way too long to play comfortably. So I looked up ways to reduce audio latency on Dolphin, and decided to change the audio library from Cubeb to WASAPI.

However, WASAPI made the audio latency even worse than Cubeb, which is the exact opposite of what people online have posted. It's like Cubeb made the input lag a quarter beat where WASAPI made it lag half a beat. There must be something wrong with my setup or the latest version of Dolphin, or both.

What steps will reproduce the problem?

  1. Set audio backend to WASAPI
  2. Start game
  3. Observe extremely choppy audio

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, encountered on 5.0-17924.

Is the issue present in the latest stable version?

No, 5.0 doesn't have WASAPI support.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

CPU: Intel(R) Core(TM) i7-8750H CPU @ 2.20GHz 2.21GHz
GPU: NVIDIA GeForce GTX 1060 with Max-Q Design
Operating system: Windows 10 Home, V21H2, OS build 19044.2251

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

I don't know where the configuration files are stored.

Actions #1

Updated by haleyhalcyon 2 days ago

Update: I changed the audio backend settings from DSP HLE emulation to DSP LLE recompiler, and the audio latency became passable.

Actions #2

Updated by JMC4789 2 days ago

Is the game running full speed? Laptops are notorious for being touchy about running full speed, especially in games without much 3D graphics. I know a few of the levels of this game have some annoying EFB/XFB effects that make them a bit demanding.

Actions

Also available in: Atom PDF