Project

General

Profile

Actions

Emulator Issues #13138

open

Mario Kart Midnight V1.1 and later crashes on Linux but not windows

Added by 9thyear2 about 1 month ago. Updated 20 days ago.

Status:
Fix pending
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Mario Kart Wii (using this riivolution patch: https://wiki.tockdom.com/wiki/Mario_Kart_Midnight)

Game ID? (right click the game in the game list, Properties, Info tab)

RMCE01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

03f069d9008e02f236372a35bc76d245

What's the problem? Describe what went wrong.

trying to use this riivolution patch on windows it works just fine, tried in windows vm
but on linux it crashes with this:

An error occurred.

IntCPU: Unknown instruction 00000000 at PC = 8025924c last_PC = 8132ffc8 LR = 800060a8

Condition: 0
File: /home/andrew/dolphin-emu/Source/Core/Core/PowerPC/Interpreter/Interpreter.cpp
Line: 347
Function: unknown_instruction

Ignore and continue?

What steps will reproduce the problem?
try to start mario kart wii using the riivolution patch with only midnight enabled on linux

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

yes, i had to build from source (more on that later (in P.S.)), 5.0-18160

Is the issue present in the latest stable version?
yes 5.0-17995

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

ASUS Prime x570-Pro
Ryzen 5 3600
EVGA RTX 2060 KO
32GB Ram
Linux

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

crashes near instantly before a log can be produced (trying to use the "show log option that's built in)

P.S. a little off topic, but with the steam deck stating to gain traction. i think its time to have an official way to install dolphin without building from source, the ppa (which i assume this is supposed to be: https://launchpad.net/~dolphin-emu/+archive/ubuntu/ppa) looks like it doesn't exist. and the flatpak is unofficial, and doesn't keep up with dolphin updates as frequently (based on looking at the commits for it and this: https://github.com/flathub/org.DolphinEmu.dolphin-emu/issues/99) they only update it every progress report. which leaves compiling from source to be the only official way of getting dolphin on linux devices (and steam deck users who have never used linux before, are unlikely to do this). and from what I've read steam deck users are going strait to the unofficial flatpak

TLDR: Have a look into different way to package dolphin for linux, because new users will avoid compiling from source


Files

image.png (17 KB) image.png 9thyear2, 01/05/2023 08:07 PM
Actions #1

Updated by 9thyear2 about 1 month ago

Pop_os 22.04

Actions #2

Updated by Zopolis4 about 1 month ago

fyi, 5.0-17995 isint the latest stable, 5.0 is.

Actions #3

Updated by JosJuice about 1 month ago

Yeah, but getting something as old as 5.0 running on Linux is a bit unreasonable.

Actions #4

Updated by 9thyear2 about 1 month ago

also to get 5.0 id have to recompile it (since there isn't any sort of package anywhere for it (talked about in P.S.). and i kinda don't want to go and recompile dolphin again if i don't have to

Actions #5

Updated by cpba about 1 month ago

I maintain the dolphin build on flathub, I'd like to clarify that we upgrade on every beta release.

Also, while the flathub build is not official, we very much would like it to be, and want to work so that it can eventually be.

Actions #6

Updated by 9thyear2 30 days ago

i just noticed that the betas are release with every progress report, the last time i used dolphin (before i started using it again 2 weeks ago) was years ago. so i was under the assumption that betas were still released about once a month.

Actions #7

Updated by 9thyear2 30 days ago

but that still means for development releases, we need to compile from source. with no other options

Actions #8

Updated by 9thyear2 29 days ago

a fix by editing the Mario Kart Midnight.xml in the riivolution folder here, and capitalizing the "l"

now we know what causes the problem, and how to fix it. so dolphin ignores caps on windows, and apparently riivolution on the wii doesn't care either.

so dolphin on linux should also probably ignore caps if possible, to prevent future issues like this from cropping up

Actions #9

Updated by 9thyear2 29 days ago

though there was another person who ran into this issue in windows 11, the vm i tested on initally was windows 10

Actions #10

Updated by JMC4789 29 days ago

I think this is an issue where Linux itself cares about capitalization.

Actions #11

Updated by 9thyear2 29 days ago

Do you think we could make a for loop that gets every filepath in the riivolution directory, then adds it to a hash table where the entire filepath lowercase is the key, and the original filepath is the value

Then whenever a filepath for a file is given we covert it to all lowercase and then get the value from the hash table with the corresponding key

This is probably harder than it sounds to implement as well, as I know c / cpp are not exactly easy per say

Actions #12

Updated by 9thyear2 28 days ago

nevermind on the windows 11, the guy didn't copy the files for the patch to the Riivolution load folder, after extracting the patch he noticed a folder called riivolution in it, so he copied the files in that folder to the Riivolution load folder, resulting in missing files that the xml was trying to load.

producing the same error

Actions #13

Updated by AdmiralCurtiss 20 days ago

  • Status changed from New to Fix pending
Actions

Also available in: Atom PDF