Emulator Issues #13208


Donkey Kong Country Returns: Freezes after Wii remote warning on multiple platforms

Added by nhubbard over 1 year ago. Updated over 1 year ago.

% Done:


Operating system:
Issue type:
Relates to usability:
Relates to performance:
Relates to maintainability:
Regression start:
Fixed in:


Game Name?

Donkey Kong Country Returns

Game ID? (right click the game in the game list, Properties, Info tab)


MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

Happens on multiple formats:

  • NKit ISO: 7f717fcaab3c1821b8224554182266d9
  • Normal ISO: d88b8280ecfd89f40b77925dfba15f9c

What's the problem? Describe what went wrong.

On the latest Dolphin dev build (18957 as of this writing), on both a 2021 MacBook Pro running macOS 13.2.1 and a custom Windows desktop running Windows 11, Donkey Kong Country Returns appears to hard-deadlock in two different situations:

  1. Windows machine: the game hard locks after the Wii remote safety warning is dismissed.
  2. Mac machine: during the boss fight for World 3 (Ruins), after completing the fight, the emulation goes to a black screen and hard locks.

Note that I am using an invincibility cheat because I kinda suck at this game, despite playing it since age 10. However, even with cheats disabled, this bug still occurs.

My config is as follows:

  • Common: DolphinBar w/ RVL-036 Wiimote, enabled custom textures loading and precompiled shaders
  • Mac: Metal graphics mode
  • Windows: OpenGL graphics mode

What steps will reproduce the problem?

Try to launch the game on Windows or play through World 3's boss on Mac with the latest development version.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Dolphin 5.0-18957

Is the issue present in the latest stable version?

Unable to test latest stable version on Mac due to lack of ARM64 JIT

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool and anyone who is building Dolphin on their own can use git bisect.)

I'd love to do a bisect in the future, but right now I'm not sure if I'm doing something wrong or if this is a bug of the

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here:

I'll happily record a Fifolog if this is a graphics issue, but I don't think it's a graphics issue right now.

What are your PC specifications? (CPU, GPU, Operating System, more)

  • Windows: Windows 11 Pro Build 23403, Intel i7-9700K, AMD Radeon 5700 XT
  • Mac: 2021 MacBook Pro 16", M1 Pro 10/16/16, macOS Ventura 13.2.1

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

I've attached logs to this bug report, and YouTube links for the screen recordings below. I can provide a savefile for the macOS crash to save time if necessary, but I'm not sure if it'll be useful because I use an NKit ISO.


Dolphin-Windows.txt (60.3 KB) Dolphin-Windows.txt Windows log nhubbard, 03/14/2023 12:35 PM
Dolphin-macOS-log.txt (535 KB) Dolphin-macOS-log.txt macOS Log nhubbard, 03/14/2023 12:35 PM
Dolphin macOS Log No Custom Textures.log (531 KB) Dolphin macOS Log No Custom Textures.log macOS Log with Custom Textures disabled nhubbard, 03/15/2023 12:23 PM
Actions #1

Updated by Billiard26 over 1 year ago

I assume everything works properly with custom textures disabled?

Actions #2

Updated by nhubbard over 1 year ago

I... didn't think of that potentially causing the issue. I'll test that real quick!

Actions #3

Updated by nhubbard over 1 year ago

Just found a completely separate issue on my Mac. I launched Dolphin to test disabling custom texture loading, it prompted me for an update, and when I tried to install the update, it showed the error message "Unable to set permissions on updater copy." I've never seen an error like this before, so I went to the Dolphin website and downloaded the update that it tried to install. When I mounted the disk image, the Dolphin Updater app had a prohibitory symbol on it, and attempting to launch it said 'You can’t open the application “Dolphin Updater” because it may be damaged or incomplete.'

Actions #4

Updated by nhubbard over 1 year ago

Issue still occurs with Load Custom Textures and Prefetch Custom Textures disabled. I also upgraded Dolphin to 5.0-18968 and that didn't fix the issue.

Screen recording: (might still be processing at high resolution)

I've attached the log from Dolphin to this response.


Also available in: Atom PDF