Project

General

Profile

Actions

Emulator Issues #13245

open

[DolphinBar] Warning message for Continuous Scanning appears when using the DolphinBar

Added by kaosjr about 1 month ago. Updated about 1 month ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Not game-related

What's the problem? Describe what went wrong.
In the Controller Settings menu, under the Continuous Scanning checkbox, there is a warning message that appears that says:
"A supported Bluetooth device could not be found. You must manually connect your Wii Remote."
This appears even when a DolphinBar is connected, which does not show up as a Bluetooth device but does support automatically connecting Wii Remotes, thus, this message is being displayed when there isn't actually any issue.

What steps will reproduce the problem?

  1. Connect a DolphinBar to your system.
  2. Open the Controller Settings menu.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.
Yes, as of 5.0-19325.

Is the issue present in the latest stable version?
No - there is no error message at all in that version (it wasn't part of DolphinWX, or the initial QT version)

If the issue isn't present in the latest stable version, which is the first broken version?
5.0-18859 was the build that added the message to Controller Settings. DolphinBar support probably just got forgotten in the process.

What are your PC specifications? (CPU, GPU, Operating System, more)
i7-8086K, GTX 1070 Ti, 32GB RAM, Windows 10 Home x64

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

You'll need a DolphinBar to verify that the message now doesn't appear when it's connected, so that may limit the devs available to test.


Files

Actions #1

Updated by Dentomologist about 1 month ago

Is the issue present in the latest stable version?
No - there is no error message at all in that version (it wasn't part of DolphinWX, or the initial QT version)

I don't have a DolphinBar and do see the message in 5.0 when I turn Bluetooth off in Windows' settings. Can you retest that with Bluetooth off, both with the DolphinBar plugged in and with it removed? Thank you.

Make sure to close and reopen the controller settings for each test, as the message only appears/disappears when the window is reopened and not while it's still active.

Actions #2

Updated by kaosjr about 1 month ago

Dentomologist wrote in #note-1:

Is the issue present in the latest stable version?
No - there is no error message at all in that version (it wasn't part of DolphinWX, or the initial QT version)

I don't have a DolphinBar and do see the message in 5.0 when I turn Bluetooth off in Windows' settings. Can you retest that with Bluetooth off, both with the DolphinBar plugged in and with it removed? Thank you.

Make sure to close and reopen the controller settings for each test, as the message only appears/disappears when the window is reopened and not while it's still active.

You do seem to be right, with the DolphinBar plugged in and not plugged in it's showing the error message in 5.0-9 & the WX version of 5.0-7062 (I can't run 5.0 proper since really old versions get mad at the SYSCONF in my NAND, so I had to run 5.0-9 portable). My bad for not fully testing, it wasn't in the early QT versions (tested with 5.0-7062) so I assumed it wasn't in WX either.
I don't have a Bluetooth adapter in my system at all since it's a desktop.

Actions

Also available in: Atom PDF