Project

General

Profile

Actions

Emulator Issues #13282

open

Skylanders: SuperChargers Racing is nearly unplayable with the emulated portal of power.

Added by TurboMeowzer 8 months ago. Updated 6 months ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Skylanders: SuperChargers Racing

Game ID? (right click the game in the game list, Properties, Info tab)

SKNP52

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

f61b088d63ab243d491b7932e9f93b9f

What's the problem? Describe what went wrong.

After completing one race, starting a second race will always make the game think the portal of power is not connected to the console when using the emulated portal of power.

This makes the Grand Prix mode of the game impossible to play through as you can't restart the game in the middle of a championship.
Adventure mode is playable, but you'll have to restart the game after every race.

Tried using both PAL and NTSC versions of the game, both have the same issue.
My Dolphin config is the default one (portable) with the only things changed being the controls.

Perhaps finding a way to "unplug and plug" the emulated portal of power can solve the issue?

What steps will reproduce the problem?

Start any race with the emulated portal of power (with a vehicle and a character), once the race finishes, start a different race.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

I tried the latest version (5.0-19672) and the version this feature was introduced (5.0-18299).
both lead to the same result.

Is the issue present in the latest stable version?

N/A, the emulated Skylanders portal of power feature isn't in the stable version.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

The first version of this feature is in 5.0-18299.
So, this has been an issue since its introduction.

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

N/A, not graphical.

What are your PC specifications? (CPU, GPU, Operating System, more)

NVIDIA RTX 2070 Super
Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz, 3600 Mhz, 8 Core(s)
Windows 10 Pro 22H2
64-bit operating system, x64-based processor
16GB RAM

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

My config is the default (portable) found in Dolphin 5.0-19672, only things changed being the controls and of course one skylander and a vehicle (Bowser and the Clown Cruiser in my case) on the emulated portal.
I have no idea how to dump the logs.

Actions #1

Updated by Mandar1jn 6 months ago

I can confirm that this is an. Issue. However, this seems to be part of a bigger issue since this also occurs on a real portal.

Actions

Also available in: Atom PDF