Emulator Issues #13305


Failed to initialize video backend on Asahi Linux

Added by omerien 4 months ago. Updated 4 months ago.

% Done:


Operating system:
Issue type:
Relates to usability:
Relates to performance:
Relates to maintainability:
Regression start:
Fixed in:


I compiled Dolphin and tried to make it play games on my Asahi Linux (up-to-date, so according to some blog posts it should support OpenGL 3.0, and I got the error "Failed to initialize video backend" while trying to start some games (see-below)

Game Name?

Tested with System Menu 4.3E and Mario Kart Wii (PAL, patched for Wiimmfi)
I tested the System Menu with a full Dolphin folder I inherited from another Dolphin installation on macOS which worked like a charm.
Mario Kart Wii was tested both with this Dolphin folder and with a clean Dolphin installation.

Game ID? (right click the game in the game list, Properties, Info tab)
RMCP for Mario Kart Wii

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

ffa2e45ace39d76e9fc2a35dac9de679 for Mario Kart Wii

What's the problem? Describe what went wrong.

Starting any of the 2 titles previously mentioned will throw the error "Failed to initialize video backend"

What steps will reproduce the problem?

  1. Try to start these games using Asahi Linux -> on an ARM Apple computer

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, this was tested on 5.0-19804

Is the issue present in the latest stable version?
I have no idea but I've checked previous attempts to run Dolphin on Asahi Linux by searching in previous issues and it failed to even compile.

If the issue isn't present in the latest stable version, which is the first broken version?

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here:

Not applicable

What are your PC specifications? (CPU, GPU, Operating System, more)

MacBook Pro 14 inches, M1 Pro.

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

RMCP was tested without savefiles and still didn't work. The logs folder contains an empty dolphin.log

Actions #1

Updated by omerien 4 months ago

I'll add the output of glxinfo | grep "OpenGL version"
"OpenGL version string: 3.1 Mesa 23.2.0-devel"

Actions #2

Updated by pokechu22 4 months ago

That's a bit odd, as PR 11628 / 5.0-19275 was supposed to fix an issue related to older versions of OpenGL ES that affected Asahi Linux, and I believe it was confirmed to be working then. Can you check if that version works?

Actions #3

Updated by omerien 4 months ago

I realised I had some libraries listed here ( I hadn't installed so I added them and recompiled the most recent version and the version you linked.

The build of the newest version completed successfully (and still has the same problem, installing the libraries I might've missed didn't fix anything)
The older build of which you linked the commit failed to even run for some reason and I got a segmentation fault (core dumped).

There is a high chance that something is wrong with my build environment; please tell me if you need any other information or checking I've done correctly some steps.
I'll add below the step-by-step process I've done to compile the older version if you want to check if I haven't failed in an obvious way I haven't seen

git clone (source of Dolphin of github)
git submodule update --init --recursive
git reset --hard 653be9e45d2b22ae67ad3c82664fa14cbc408866 (this is the ID of the commit you've linked)
(I've then tried to compile by making a folder and then the usual cmake .. and make -j$(nproc), which failed at some point for some code which hadn't been modified in 2 years, so I figured out reinstalling the submodules after the downgrade couldn't be a bad thing)
git submodule update --init --recursive
(The compilation process, which this time didn't fail)
Running the binaries then gave the segmentation fault.

Actions #4

Updated by omerien 4 months ago

Because I try random stuff sometimes, I used the no-gui binary with my Mario Kart Wii WBFS... and it ran without issue on both builds. I couldn't actually use the game because no buttons were assigned but I got to the title screen without issues; my old Dolphin folder I imported from another computer also worked.


Also available in: Atom PDF