Project

General

Profile

Actions

Emulator Issues #13360

closed

Dolphin crashing like fucking hell after WiiConnect24 KD scheduler got implemented

Added by Larsenv 9 months ago. Updated 9 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

No

Game ID? (right click the game in the game list, Properties, Info tab)

No

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

Who even uses MD5 hashes anymore?

What's the problem? Describe what went wrong.

Dolphin will crash on literally anything after 1-2 minutes ever since Sketch implemented KD scheduler. I'm using M1 Pro MacBook Pro on ARM mode. I can't even use the emulator properly. He blocked me for like the 5th time which prevents me from asking him what's up, and he's probably trying to make a Wiimmfi clone for Dolphin integration, so he can't properly hear me.

What steps will reproduce the problem?

Literally just open anything on Dolphin and it will crash.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes sir.

Is the issue present in the latest stable version?

You can't even run stable version on ARM.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

20120 (fuck bisecting)

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

No.

What are your PC specifications? (CPU, GPU, Operating System, more)

MacBook Pro 14-inch 2021 16 GB Ventura 13.5.2

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Dolphin needs to quit walking on eggshells to please Nintendo, y'all are overly worried that Nintendo will be knocking on your door. Sorry for the badly written issue. I'm in that kind of mood.

Actions

Also available in: Atom PDF