Emulator Issues #13397


Ultimate Spider-Man Flickering/Missing Textures

Added by tagger101 22 days ago. Updated 15 days ago.

% Done:


Operating system:
Issue type:
Relates to usability:
Relates to performance:
Relates to maintainability:
Regression start:
Fixed in:


Game Name?

[Ultimate Spider-Man]

Game ID? (right click the game in the game list, Properties, Info tab)


MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)


What's the problem? Describe what went wrong.

Running Ultimate Spider-Man on multiple backends is difficult due to flickering textures and missing buildings. I've provided a video of this issue in action on Discord (Spoke to moderator InfoManiac on 11/17/23) but can't upload it here due to file size limitations.

What steps will reproduce the problem?

-Freshly installed Dolphin v5.0-20347 in portable mode
-Ran the game
-Noticed extreme texture issues throughout the game, no specific location

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes. Tested on v5.0-20347

Is the issue present in the latest stable version?

Unsure, only tested on latest dev version and also version 5.0-19368 (this older version does NOT have the issue, but all newer versions do)

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool and anyone who is building Dolphin on their own can use git bisect.)

All versions newer than 5.0-19368 are affected.

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here:

I'm happy to send a 24mb video of the issue as I did on your Discord server, I'm having a hard time understanding what is being asked for here. Screenshots will not convey the issue properly, please check Discord for the video I uploaded or contact me directly (username saulsballs)

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel i9-13900k, Strix RTX 3090 24gb, Win10 Home 64 bit, 64gb DDR5 memory

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)



Capture.PNG (31.6 KB) Capture.PNG tagger101, 11/18/2023 05:09 PM
Actions #1

Updated by JosJuice 21 days ago

All versions newer than 5.0-19368 are affected.

So this means that 5.0-19370 is affected?

Actions #2

Updated by tagger101 21 days ago

JosJuice wrote in #note-1:

All versions newer than 5.0-19368 are affected.

So this means that 5.0-19370 is affected?

Apologies Jos! That's incorrect.

After testing multiple dev builds sequentially (painstakingly I might add, the bisecting tool listed in the instructions is sadly no longer working) it seems dev build 5.0-19413 is the culprit. This is when the issues with textures arise in Ultimate Spider-Man. The prior dev builds don't have the issue.

If it means anything I also ran into this error (attached image) often while testing these dev builds which is strange as I haven't experienced this before.

Actions #3

Updated by JosJuice 21 days ago

Have you tried disabling dual core?

Actions #4

Updated by tagger101 15 days ago

JosJuice wrote in #note-3:

Have you tried disabling dual core?

Sorry for the delayed response. Yes I tried disabling dual core to no noticeable effect.

In the past week I re-dumped my game 3 times (just to eliminate any significant chance of a bad dump regardless of the verification coming back as good), I've tested multiple builds with multiple settings, and I found something that could be a lead.

I'm now able to reproduce the issue on older builds as well (such as 5.0.19368). Once the issue of flickering buildings/textures happens, it doesn't go away until I load an old save. Interestingly enough, if I save a state while experiencing this glitch and then load that saved state, the issue shows itself immediately. It seems to be baking itself into the savestate if that makes sense.

Not sure if this information can help narrow down the issue, but it seemingly happens just from playing for any period of time (it's happened to me after <1 minute before, and also after 10 mins of play-time).


Also available in: Atom PDF