Project

General

Profile

Emulator Issues #1365

Frameskip causing black frames flickering on DX9

Added by bruno.serafim59 almost 11 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1.Using DX9 Plugin
2.Setting the frameskip to 1~9

What is the expected output? What do you see instead?
Well, it should work like in the OpenGL Plugin. But, instead, it flickers
with black frames, in and out. The lower the frameskip rate is, the faster
it will flick.

What version of the product are you using? On what operating system?
Running on Rev 4182 with Windows x86, but so far I tried all recent Revs
and all of them had this problem.


Related issues

Is duplicate of Emulator - Emulator Issues #1424: D3D Plugin : Frame skipping causes a nasty flashing.Fixed

History

#1 Updated by death2droid almost 11 years ago

The frameskip wasn't built for the D3D plugin meaning there are going to be a lot of
bugs with it and the D3D plugin.

#2 Updated by sl1nk3.s almost 11 years ago

  • Status changed from New to Fixed

r4194

#3 Updated by marcus almost 11 years ago

  • Status changed from Fixed to Duplicate

It appears not...

NOTE: I am merging this issue into one which was reported afterwords because that one
has more complete information and is more recent.

Also available in: Atom PDF