Project

General

Profile

Emulator Issues #1451

Sonic Unleashed Hangs again

Added by ssonicegypt over 11 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Run Dolphin
2. Run the Game
3. Start Stage 2 in Sonic Unleashed (wii)

What is the expected output? What do you see instead?
Expecting To See Stage 2 Starting But it hangs during the loading after
reaching the goal ring in stage 1. and it also crashes in holaska stage
and some other stages (not all) after reaching any goal ring even with a
dumbed save file from the wii.

What version of the product are you using? On what operating system?
Dolphin 4312

Please provide any additional information below.
This Game used to Work starting of Revision 3155 and it doesn't work any
more Starting from Revision 3500 Until now. I attatched a save file that
automaticly directs you to Stage 2 so you (devs) can go to stage 2 without
watching the whole cut scene , hopefully this helps :)


Related issues

Is duplicate of Emulator - Emulator Issues #398: Sonic Unleashed Hangs During Level 2 LoadingFixed

History

#1 Updated by ssonicegypt over 11 years ago

Since I can't edit my post then I will have to retype those correctly:

What steps will reproduce the problem?
1. Run Dolphin Emulator
2. Run the Game (Sonic Unleashed for the Wii)
3. Start Stage 2 in Sonic Unleashed wii

#2 Updated by jayork42 over 11 years ago

You're good, we know what the game is. :)

#3 Updated by ssonicegypt over 11 years ago

lol Great. here are more information i just recieaved

it happens using the DX9 or the open GL plugin.
I mannaged to click random keys becuase i can't see using the DX plugin and entered
a pre save files that contains all stages and some how entered holaska and it did
crash. if you want to test just use the DX9 plugin and keep clicking the A button.

at any ways , at this rate I don't think its an Open GL problem. but Feel Free to
test , I also think its an Open GL/DX9 Related problem but not an Open GL problem as
I heard before that the open GL fails to compile some thing but fails (sorry not
good at programming XD). I think its with "Jitdynacre" , Oh and i am running the 32
Bit version.

Hopefully I given enough information about this issue ^

#4 Updated by sl1nk3.s over 11 years ago

Hmm, why was the 'hack' removed ? did it break some games ?

#6 Updated by ssonicegypt over 11 years ago

Well with no doubt you are right.
it did break some thing got removed starting from 3500(I think)
I used to get a black screen (without the Zelda Graphic Hack) and I don't see it in
Version 3500 until 3700 also some known graphical issues got removed on Revision
3500 (Which is the Revision that Re-Started the Crash).. I am not sure if they are
related.

but is this going to be fixed? Maybe a Hack Option with "Options --> Configure -->
Advanced" , I don't know any thing about C++ or even other codings.

is this going to be Fixed?

Thanks for every thing regardless , I am patient.
rock on , dolphin team :)

#7 Updated by ssonicegypt over 11 years ago

also please notice. don't mix the 2 bugs (issue 1008) with this one.
this one Crashes during the loading screen that should start stage 2

Thanks once again.

#8 Updated by LinesPrower over 11 years ago

The 'hack' has been removed because it's a hack and it does some wrong things (and
seems to cause issue 1008). Howewer you can add those 4 lines back to the fcmpo/fcmpu
code to fix Unleashed. Or you can use Dolphin IL. It has fcmpo/fcmpu JIT'ed with this
hack.

#9 Updated by ssonicegypt over 11 years ago

that error was in sonic Unleashed too way long time ago (issue1008) 0.o
but maybe the japanese version only had issue 1008 starting the game its self.

I will try dolphin IL. I am not good at coding and don't know how to compile \x

#10 Updated by ssonicegypt over 11 years ago

Cool! DolphinIL Works!

Thanks Dolphin Devs for the great emulator and also thanks Lines power for the info!
(are you a dolphin dev btw?)

Thanks again!! keep it up!

#11 Updated by LinesPrower over 11 years ago

  • Status changed from New to Duplicate

#12 Updated by DiscoBiscuit03 almost 11 years ago

I'm having a problem with sonic unleashed. I get to the first dialog part where the little guy says "wow you're all blue and spiky" or something and it says press A, but it doesn't work. I've tried every button on the keymap and nothing works except the home button (brings up wii menu). What do I do?

#13 Updated by racerbeograd over 10 years ago

what to do when you download the file,im new with dolphin!!!!!!!!!

#14 Updated by racerbeograd over 10 years ago

what shoud i import when i try to import anything from there it doesnt work,help

#15 Updated by illution.inc over 10 years ago

Having the same problem as DiscoBiscuit03 . Why can't we press A? Did you figure it out man?

Also available in: Atom PDF