Project

General

Profile

Emulator Issues #147

Luigi's Mansion suffers incredible slow down when in the mansion with the DirectX plugin (but works correctly when using OpenGL)

Added by knuckles500 almost 12 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Load any version of Luigi's Mansion
2. Make sure you're using REV242 x64 with dual core on, and most
importantly, use the DirectX plugin
3. Start a new game and wait until you get into the Mansion

What is the expected output? What do you see instead?
To see everything, but you only see the GUI. The framerate goes to 1fps.

What version of the product are you using? On what operating system?
Dolphin SVN Rev242 x64. Windows XP Pro x64

Please provide any additional information below.
I think I know the problem with this one. The OpenGL plugin can emulate
reflections (Like Fountain of Dreams (See issue 95) - the reflection from
the water - in SSBM) without error, which is the same sort of effect for
the mirror in the Mansion. When using the DirectX plugin, if you see this
mirror like video effect, Dolphin decreases the fps to 1-6fps and stays.
Here's a screenshot of what it looks like using the OpenGL plugin. Awsome,
I have to say as it also emulated the smoke/fog very well when Luigi is
walking around.


Related issues

Is duplicate of Emulator - Emulator Issues #281: DX9's CopyEFBToRenderTarget Not as complete as GL versionFixed

History

#1 Updated by knuckles500 almost 12 years ago

And here's a screenshot with DirectX.

#2 Updated by 4luC4rD.h3lls1nG almost 12 years ago

I have the same problem but can't play with ogl, the plugin makes the emu crash when
I start the emulation, (I have an ati x1600), and I agree with you knuckles500, I
also think it is the same problem that makes Fountain of Dreams slow down.

#3 Updated by federelli almost 12 years ago

There is much less of a slowdown in revision 667, only the flashlight and vacuum look
weird, and there's some general blurryness.

#4 Updated by knuckles500 over 11 years ago

With R937, I think this was fixed. I know OpenGL worked well with this game, but I
think DirectX is working better as well.

#5 Updated by Anonymous over 11 years ago

Just would like a confirmation it's fixed, never had the problem myself, so i can't
test it. :p

#6 Updated by knuckles500 over 11 years ago

No more bad slow down, but we have another problem with the video...look at the
attachment.

I have no idea what's going on. The opening cutscene is fine, but when you get in
the game however, it's disgusting. I don't see Luigi's shadow, in some areas Luigi's
eyes are missing, the dust effect isn't displaying at all. And most importantly, the
screen is as if the blur effect on the mirror is covering the entire screen instead
of just that portion of the map.

The video displays correctly using the OpenGL, and none of those problems occur. So
I guess DirectX needs some catching up to do. :P

Offtopic: How long was the "Nintendo" voice sample working? I don't remember it ever
working, but apparently it plays the sound now. Cool.

#8 Updated by Sonicadvance1 over 11 years ago

Not really a game issue, it affects SSBM as well. It's due to CopyEFBToRenderTarget
in TextureCache.cpp not being as complete as the GL one called
CopyRenderTargetToTexture in TextureMngr.cpp. I'll just create a new issue though
since this one is just related to Luigi's Mansion

#9 Updated by XTra.KrazzY about 11 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF