Project

General

Profile

Emulator Issues #149

R253 - Invalid Read in ZWW

Added by inseparables42 over 12 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Run Wind waker With Patch Fix item Enabled
2. play 1 minute.

What is the expected output? What do you see instead?

The game do an error TLB with the patch fix item enable. If i disables it
i don't have crash.I think it's the same problem that i post before , but
now i have a error message , before that , i just had a crash.

What version of the product are you using? On what operating system?
I use REV 253 , windows vista 32 bit , geforce 8800 , 3 Ghz ram.

Please provide any additional information below.

History

#1 Updated by MasterPhW over 12 years ago

Is it still there or can this issues be closed?

#2 Updated by ChristopherULJ over 12 years ago

Can confirm this using the latest revs.
I tried to reproduce during the last 30mn, and can confirm that it's the "item hang
fix" which is causing this kind of crash.

It's not random though, when the fix is activated, doing simple things such as
breaking a pot, jumping into water etc.. can cause Dolphin to crash blaming the
unimplemented TLB.
The fix also seems to disable everyone's shadows since rev409-426 ?! (cause it fixed
this while disabling the fix, really unintended)

Disable the fix, and everything is back to playable as it was with rev ~200 :/

#3 Updated by ChaosCode over 12 years ago

Im pretty sure this is fixed. can we get a recheck? If so lets get this closed. time
to clean up the tickets a bit.

#4 Updated by XTra.KrazzY over 12 years ago

Don't forget that this error used to be followed by something like "Redundant @MOV"

#5 Updated by AHeinerm over 12 years ago

REV 253 is pretty old. This was probably fixed.

#6 Updated by omegadox over 12 years ago

  • Status changed from New to Accepted

btw, the issues is not related to TLB, it is just an invalid read.

#7 Updated by nakeee over 12 years ago

how come this issue is still here?
can someone try newer build?:)

#8 Updated by slink_3_ over 12 years ago

Hmm... it doesn't crash anymore using the latest rev + patch enabled, it must have
been fixed lately, because i'm pretty sure it was still crashing about ~200revs ago

So you can close it :)

#9 Updated by Anonymous over 12 years ago

  • Status changed from Accepted to Fixed

#10 Updated by mentrei about 12 years ago

Ok, revision 1943
"Fix Item Hang" enabled - Dolphin crashing for nothing
"Fix Item Hang" disabled - Dolphin runs the game just fine for hours, of course,
without picking any item.

#11 Updated by slink_3_ about 12 years ago

yes, it's still crashing randomly..
I was being a bit optimistic when i said it was fixed :/

Also available in: Atom PDF