Project

General

Profile

Actions

Emulator Issues #1517

closed

Closing out of game closes out of dolphin as well.

Added by alienrubbert over 14 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1.Load game
2.Close game via X

What is the expected output? What do you see instead?
To return to Dolphin main screen.
Dolphin closes all together.

What version of the product are you using? On what operating system?
r4384 on Windows 7

Please provide any additional information below.
AMD Athalon 64 Dual-Core 5600+ 2.86Ghz
2 GB DDR2 RAM
Nvidia 8600 GT x2
Windows 7 RC x86

Actions #1

Updated by GCNWIIUploader over 14 years ago

thats supposed to happen. Just use stop

Actions #2

Updated by alex.waters over 14 years ago

I think what alienrubbert is specifically refering to is when playing in windowed
mode - not rendered to main window. I don't think it should happen with the windowed
mode though. It feels non-standard and I frequently make the mistake of trying to
close the current emulation by just closing the emulation window and expect to return
to dolphin.
While it doesn't overly matter since Dolphin start-up times are... Well, it's
instant, lol. It's just odd.
Though I don't think a child window should have to power to kill the main process -
that has to be some form of bad design practice or something. (please take note - I'm
not trying to be rude about design procedures! I'm just saying that there are many
people that would consider this "wrong" in their little world - it just feels like a
private/public variable class violation thing, lol).

Actions #3

Updated by XTra.KrazzY over 14 years ago

  • Status changed from New to Invalid

Closing in the DX9 plugin calls exit(1), which exits the entire program

Actions #4

Updated by alex.waters over 14 years ago

Ummm... I think the point of this issue was not that it was an "unknown cause" - that
fact that it exits is known, but that it shouldn't call exit() - that should be the
main windows job.
A similar thing occurs with the OGL plugin if it fails to create; which actually
causes Dolphin to "crash" because the wx stuff isn't being deleted in the right order

  • not that it matters since the entire program is closing anyways, just a bit dirty having a crash message coming up though.
Actions #5

Updated by alienrubbert over 14 years ago

Alex.waters is right. I think it shouldn't just close altogether but return to the
parent screen. Not that it's a crucial fix. Just a way for me to shave an extra click
to load the file up again.

Actions

Also available in: Atom PDF