Project

General

Profile

Emulator Issues #1539

Missing Instruments in Some Games

Added by knight0319 over 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
DSP
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

I'm not 100% sure if this has been reported or not, but if it has, please
ignore.

What steps will reproduce the problem?
1. Just attempting to play some games. For example, Tales of Symphonia.
Normally, it should play the music in the game fine. All the voices are
fine, it's just the music that is the problem. You can't really listen to
the music at all because of the missing instruments, or whatever.

What is the expected output? What do you see instead?
Music should work perfectly, as in no missing instruments.

What version of the product are you using? On what operating system?
SVN 4412

Please provide any additional information below.
Other than the missing sounds for the music, the game works perfectly,
excluding the FPS sometimes dropping a bit and lagging, but I can live
with that.


Related issues

Is duplicate of Emulator - Emulator Issues #4452: DSP HLE has various instances of producing the wrong and/or no outputInvalid

Has duplicate Emulator - Emulator Issues #2253: Resident Evil Remake - BGM IssueDuplicate

Has duplicate Emulator - Emulator Issues #2996: music is very slow in tales of symphonia Duplicate

Has duplicate Emulator - Emulator Issues #3337: [Mario Golf] Music plays extremely slowDuplicate

Has duplicate Emulator - Emulator Issues #3485: Resident Evil Remake BGM missing sounds and sudden stopsDuplicate

Has duplicate Emulator - Emulator Issues #3509: Tales of symphony missing sounds when music is playing Duplicate

Has duplicate Emulator - Emulator Issues #3574: BugsDuplicate

Has duplicate Emulator - Emulator Issues #5052: Wind Waker & Twilight Princess Music "Different" Duplicate

History

#1 Updated by knight0319 over 10 years ago

Forgot to mention I am running Vista Home Premium 32-bit.

#2 Updated by Xtreme.Starfox over 10 years ago

Skies Of Arcadia and Pokemon Colosseum also have this problem.

#3 Updated by Flare7571728 over 10 years ago

I've noticed this problem in both of the metroid primes and in Pikmin, and slightly in
super mario sunshine

#4 Updated by Flare7571728 over 10 years ago

Mario Kart has missing sound elements as well.

#5 Updated by knight0319 over 10 years ago

Hm, anybody know of the current status of this issue? I'm still running R4429 as I
haven't bothered to upgrade recently.

#6 Updated by luisr142004 over 10 years ago

yea it's fixed :)

#7 Updated by Xtreme.Starfox over 10 years ago

It didn't fix anything for Skies of Arcadia & Tales of Symphonia for me, It's exactly
the same missing Instrument effect as always.

Build 4631.

#8 Updated by knight0319 over 10 years ago

Hmm, any good performance enhancements since R4412 then to the latest version at the
moment? (R4658).

Still hoping they can work on that issue soon. I've gotta settle for playing songs
from the Tales of Symphonia OST accordingly with what song is supposed to be playing
to make it more of a happier gaming experience.

#9 Updated by SethHikari over 10 years ago

Still missing instruments in Pokemon colloseum. This sounds really weird so it is no
fun to play when all I hear is the E and G of piano and some harmonicas.

#10 Updated by fjavier2k over 10 years ago

Tried r4711. Skies of Arcadia still with the same issue of missing instruments as you
can see in the opening intro that appears after pressing start and selecting "New
game" option. It's a pity because it is a game with a beautiful and epic soundtrack.

Here I leave two videos so you can see the problem well:
Here is how it sounds on the original gamecube:
http://www.youtube.com/watch?v=zRsw22a7PD8

Here you can see how it sounds with dolphin:
http://www.youtube.com/watch?v=djYuy1fYVm0

#11 Updated by knight0319 over 10 years ago

Ah. Well, I tried r4712 today. I noticed it runs slower than r4412 while using D3D
(I seriously need to hurry up and get my hands on a ATI 4850, this X1300 Pro isn't
doing my justice anymore). But anyways, it seems like some of the music has been
improved ever so slightly, it may sound slightly better if I can get a new graphics
card soon, but I can still tell quite a few instruments are missing.

To be honest, I wish this was one of their priorities to get fixed. Fix the problem
that most people are having before fixing little things that aren't that important.

#12 Updated by knight0319 over 10 years ago

Updated to r4724 to the second phase of the reworked sound system. Still no
improvement at all in Tales of Symphonia. Still the good ol' missing instruments
that we've grown to hate. Heh.

#13 Updated by marcel.werner3 over 10 years ago

I'm not sure if this issue is the same that I'm experiencing in games like Mario
Party 4 & 5, Mario Power Tennis, and maybe more of the bunch...
Audio still needs some work, indeed.

#14 Updated by zantezuken over 10 years ago

Confirmed issue since 1xxx revisions :P

#15 Updated by bourgeoisdude over 10 years ago

Same issue. Playing ToS NTSC version. I've tried on AMD Athlon X2 4400+ w/ NVIDIA
8600GTS PC and Core i7 920w/8800GT. Vista 32-bit and Windows 7 64-bit. Same issue in
OpenAL too. 32-bit and 64-bit versions. Weirdly enough (and I don't know if it's
related), the second disc's intro video plays perfectly but the first one stutter's
in specific spots, same way on both PCs again regardless of Dolphin settings.

#16 Updated by knight0319 over 10 years ago

Still no progress made on this problem. Wish they would work on this.

#17 Updated by ploup.pagniez about 10 years ago

bourgeoisdude : Intro video on disc 1 used to stutter. I don't know if it's because
i'm using a newer revision, but it's (apparently) gone, I don't hear this glitch anymore.

#18 Updated by idiosyncinc about 10 years ago

Running r5150 and I experience the same problems. Stuttering video on disc 1 and
missing instruments for music in TOS. During the opening story scene I used to have
stuttering but enabling bi/tri textures fix that stuttering.

#19 Updated by Rygdea about 10 years ago

@knight

Have they even acknowledged this problem yet?

#20 Updated by bourgeoisdude about 10 years ago

FYI, issues exist in v2.0 RC1.

#21 Updated by edwin.cl.chan88 about 10 years ago

same problem, bgm sounds missing

#22 Updated by oltareb about 10 years ago

Same problem with v 2.0

#23 Updated by Rygdea about 10 years ago

I find it strange that they don't accept it, but don't refuse to fix it either....
It's like they don't acknowledge the problem exists at all. >.>

#24 Updated by LM1234 about 10 years ago

  • Status changed from New to Accepted

It's a known problem with DSPHLE, but dunno how to fix it atm.
This is ok under DSPLLE (but low speed is causing other problems there).

#25 Updated by marcel.werner3 about 10 years ago

Hey, not sure which commit exactly did it but this issue has "changed". Or let's say it
has gotten better (though still not perfect).

#26 Updated by bourgeoisdude about 10 years ago

Which build are you using, marcel?

#27 Updated by marcel.werner3 about 10 years ago

The latest one, r5437

#28 Updated by alec20 almost 10 years ago

Any progress being made towards this?

#29 Updated by amir9380 almost 10 years ago

Then,this issue is alway here ?

But i don't understand,tos is the best rpg of gc

So why,nobody want to fix this problem

Please dev,fix this issue...

#30 Updated by petergodofsky over 9 years ago

Having this issue as well, identical problem, identical OS (Vista Home Premium 32bit)

#31 Updated by jeffowens08 over 9 years ago

With Tales of Symphonia, a combination of disabling "Idle Skipping" and using the OpenAL backend seems to improve the issue somewhat, at least as of r6218. This is easily tested with the main menu music..the difference is very obvious. Nonetheless, the issue remains.

#32 Updated by marcel.werner3 over 9 years ago

hmmm, strange...I thought this issue was strictly HLE-related...

#33 Updated by skidau over 9 years ago

issue 2996 has been merged into this issue.

#34 Updated by skidau over 9 years ago

issue 2253 has been merged into this issue.

#35 Updated by skidau over 9 years ago

  • Category set to dsp

#36 Updated by skidau over 9 years ago

issue 3485 has been merged into this issue.

#37 Updated by skidau over 9 years ago

issue 3509 has been merged into this issue.

#38 Updated by skidau over 9 years ago

issue 3337 has been merged into this issue.

#39 Updated by hatarumoroboshi over 9 years ago

Don't know if it is related with this issue, but I want to inform that in Resident Evil Code Veronica X some sound effects are missing, like for example at the beginning of the game when you equip the lighter, when the guard drops the medicinal, the waterdrops not hearing and even the sound of the usual Resident Evil change screen (opening door) is missing...

#40 Updated by skidau over 9 years ago

issue 3574 has been merged into this issue.

#41 Updated by bourgeoisdude over 9 years ago

Are we sure that the sound issues in all these games are related to the same issue?

#42 Updated by carlos.ismael.braz over 9 years ago

No news about this bug?

#43 Updated by MofoMan2000 over 9 years ago

Best way to get news on a game's compatibility is to try it yourself.

Also, if this has anything to do with issue 326 then it's not fixed.

#44 Updated by carlos.ismael.braz over 9 years ago

I've tested this issue again in Tales of Symphonia, with the latest revision (r6591 x86) and it still has the same buggy music.

#45 Updated by georges.messager over 9 years ago

Well, I got some interesting behavior in Tales of Symphonia while playing. Hope it can help in some way.

On the world map, during some of these scenes with the party chatting in green boxes (it's called "sayn├Ętes" in French, don't know in English version), some bug (I tried to save using Shift+F1) killed all graphics but the chatting scene itself (the game didn't crash). From this moment, the music started to play perfectly (it was buggy as always before that).

Because most of the CPU/GPU usage had been freed when the main graphics stopped, I guess the game was running at almost native speed. That's what leads me to think that this problem is due to some mandatory synchronization between music and graphics, in which starting instrumentation is skipped if the graphics are too slow.

BTW, I'm using r6861, DSP-HLE and DX9 under Win7 x64 (4-core)

EDIT: I have been trying to record this with FRAPS, but each time I start the video capture, Dolphin crashes and I'm to lazy to fix it.

#46 Updated by Deluneth about 9 years ago

Still having the issue with latest rev 7389 on Tales of Symphonia. The music is buggy and sounds like it's missing parts, yet the game runs close to perfect. Tried the LLE plugin, and it drastically reduced the speed and made everything even worse. Can't believe this hasn't been fixed yet...

#47 Updated by marcel.werner3 about 9 years ago

It probably never will...HLE is pretty tough to figure out; that's why the devs have pushed the LLE plugin, it doesn't have most of the issues the HLE is having. Indeed, for most people LLE is still too slow (for me as well -_- ), but I doubt this issue will ever be fixed with HLE.

#48 Updated by Anonymous about 9 years ago

  • Status changed from Accepted to Duplicate

#49 Updated by skidau over 8 years ago

issue 5052 has been merged into this issue.

Also available in: Atom PDF