Project

General

Profile

Emulator Issues #1746

Metroid Prime 1 X-Ray Visor no longer works

Added by darrenkiel over 10 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Start Metroid Prime
2. Turn on X-Ray Visor

What is the expected output? What do you see instead?
Expected output is normal x-ray vision. Instead you get a white haze over
everything and you can't see anything.

What version of the product are you using? On what operating system?
JIT x64 R4647
Vista x64
ATI Mobility Radeon 4670

Please provide any additional information below.
May be related to the following issue, which has been "fixed":
http://code.google.com/p/dolphin-emu/issues/detail?id=1708&can=1&q=metroid%
20prime

History

#1 Updated by darrenkiel over 10 years ago

It may have been caused by this update, can someone confirm?

http://code.google.com/p/dolphin-emu/source/detail?r=4618

#2 Updated by darrenkiel over 10 years ago

Update: seeing same x-ray visor problem with R4613 so I've confirmed this is NOT
related to the above issues.

#3 Updated by ugoobieze over 10 years ago

try turning of safe texture cache that's what i did when i had this problem and it
fixed it

#4 Updated by Autoran1 over 10 years ago

Fixed with EFB to RAM in D3D

#5 Updated by darrenkiel over 10 years ago

You're right - thanks - though turning off safe texture cache causes other strange
graphics problems. Maybe that's a known issue though, not sure.

#6 Updated by ugoobieze over 10 years ago

yeah it is metroid prime need safe texture cache so you can read any writing in it but
this then cause problems for other things that require the EFB to RAM function such as
X-Ray visor and Thermal visor

#7 Updated by Anonymous over 10 years ago

  • Status changed from New to Invalid

Also available in: Atom PDF