Project

General

Profile

Emulator Issues #1870

Wiimote doesn't work for "Sonic Riders Zero Gravity"

Added by styleryo over 10 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Run Dolphin
2. Open Sonic Riders Zero Gravity (PAL)

What is the expected output? What do you see instead?
Wiimote Status is connected, but no buttons are working at all.

What version of the product are you using? On what operating system?
Tested on r4682 and r4727 (Windows 7 64bit).

Please provide any additional information below.
Other Games like Mario Kart Wii or Super Mario Galaxy work fine.

History

#1 Updated by ggohdin over 10 years ago

It never has worked, same as dbz - tenkaichi 3, castlevania, dragonball - revenge of
king picollo. It to me doesnt seem very high in priority concidering all 3 games can
use a wavebird (controller), under the games options.

#2 Updated by ayuanx over 10 years ago

How about latest version?

#3 Updated by styleryo over 10 years ago

nope it's still not working with r4760, but the home button on the wiimote works! :)

p.s. The home button worked already on older revisions (just tested on r4717)...

thanks!

#4 Updated by ayuanx over 10 years ago

If "Home" works, that means the wiimote is connected and working good, maybe you
should check your button mapping?

#5 Updated by styleryo over 10 years ago

I think the button mapping is fine, because other games like Mario Kart Wii works.

#6 Updated by jemyp79 over 10 years ago

I agree. For exemple, when you are in the "Home" screen, "A" button works perfectly,
but when you back in the game doesn't... Sorry for my english

#8 Updated by mirkoilmigliore over 10 years ago

guys in config go in gamecube where there is enough to set the "standard
controller" to "nothing" and you're done you connect real wiimote and play with
tenkaichi 3 !!!!!!!

#9 Updated by ayuanx over 10 years ago

  • Status changed from New to Questionable

#10 Updated by styleryo over 10 years ago

it works, thanks for solving this ^

#11 Updated by ayuanx over 10 years ago

  • Status changed from Questionable to Invalid

#12 Updated by snzgoo over 10 years ago

works, cheers, who woulda thought of that...

#13 Updated by sonic4sale over 10 years ago

I worked out it was because I had the Gamecube controller plugged in and it chooses
that as first preference. Unplug your Gamecube controller if you want to use a Wiimote
or leave it in if you want to use classic controls (much better).

Also available in: Atom PDF