Project

General

Profile

Emulator Issues #1991

"Wii Menu->Wii Settings" shows black screen

Added by ayuanx over 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

It is because the unimplementation of /dev/net/ncd/manage & /dev/net/kd/request

e.g.
case IOCTL_NCD_GETLINKSTATUS:
// 0: unknown, 1: link down, 2: link up
*Memory::GetPointer(CommandBuffer.PayloadBuffer[0].m_Address) = 1;
ReturnValue = 0; // Success
break;

But there are a lot more CMDs to investigate.


Related issues

Is duplicate of Emulator - Emulator Issues #661: Wii-Menu Problems: Address book, Memo, Game Booting, GC Disc Recognition, SettingsFixed

History

#1 Updated by Anonymous over 10 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF