Project

General

Profile

Emulator Issues #2119

Fzero (and other TLB games) needs the 32bit Dolphin fixed to reach full speed (slow memory access)

Added by wespipes69 about 10 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Just a reminder here that the 32bit JITIL needs to have the slow memory
access with TLB fixed.

Quote from dev discussing making Fzero playable: "Temporarily forced JITIL
to use the slow memory access for Win32 when playingtlbhack games."

Fzero is fine on 64bit but it's next too impossible to get full speed on
32 bit version (Grand Prix).

Also, I took that to mean I could use just JIT, but using that causes a
crash trying to access the title screen.


Related issues

Blocks Emulator - Emulator Issues #2043: Release bug trackerFixed

History

#1 Updated by XTra.KrazzY about 10 years ago

  • Status changed from New to Questionable

#2 Updated by Autoran1 about 10 years ago

This issue is real, now all TLB games run completely slow or unsatble with major
slowdowns

#3 Updated by federelli about 10 years ago

Having a 32bit only computer nowadays is non-standard.

#5 Updated by wespipes69 about 10 years ago

I don't think so federelli. What numbers are you looking at? Does everyone have a
HDTV also? :) Either way, the emulator will continue for a long time to support 32
bit as it should, and as this is a 32 bit issue, it should be addressed.

With this fix, every single GC and Wii game will run full speed - so no need for a
64 bit there. Also, because I don't have rumble at all on the 64 bit version, im
forced to use the 32 bit until that's fixed.

#6 Updated by ksg017 about 10 years ago

VERY confused why a developer would place this as "questionable" when another
developer has already stated that the win32 TLB hack is in slow memory access.

Just for reference it was Commit 4862 that caused this.
http://code.google.com/p/dolphin-emu/source/detail?r=4862 Infact, hrydgard stated a
week ago on issue 2072, "Yeah, this is known, JitIL 32-bit was slowed down through a
hack to make F-Zero work. I'll be working on finding a better solution and getting
the speed back up later this week." I think krazzy made accidental mistake when he
labeled it questionable lol.

#7 Updated by hrydgard about 10 years ago

  • Status changed from Questionable to Work started

This is not Questionable. I need to get around to fixing it somehow. :p

#8 Updated by nakeee about 10 years ago

If there is a reasonable way to fix it I think it should be marked as release blocker..

#9 Updated by darksonic_ds about 10 years ago

So if this is fixed... the speed with n64 games on dolphin will be perfect, right?

#10 Updated by flow3184 about 10 years ago

darksoni, a short answer: no

#11 Updated by ksg017 about 10 years ago

I have not compiled and tried this patch but a member on the forum has posted a
patch. Lets see how this goes.
http://forums.dolphin-emu.com/thread-7257-post-68274.html#pid68274

#12 Updated by wespipes69 about 10 years ago

Any comments on this. Been around for days and no one has said a word about it. Does
it work? Will this be officially commited soon. I'm sure alot of 32bit users have
been waiting to play Fzero. Look forward to seeing this be part of the SVN soon
provided it doesnt cause too many other problems. No matter what, Fzero is worth
it! :P

#13 Updated by ksg017 about 10 years ago

So has there been any news in the last month on a developer coming back to fix the 32
bit tlb hack?

#14 Updated by skidau over 9 years ago

I have relieved this issue slightly in r6036. It is not completely fixed but speeds should be faster than before. JITIL speed has been restored. It is now faster to play F-Zero GX in JIT 32bit mode.

#15 Updated by Anonymous almost 9 years ago

skidau: can this be marked as fixed or something?

#16 Updated by skidau over 8 years ago

  • Status changed from Work started to Won't fix

I think it is safe to say that this issue was too hard to fix :( It'll have to be another advantage that the 64bit version has.

Also available in: Atom PDF