Project

General

Profile

Emulator Issues #2140

efb access quality/scaling issue

Added by kevinx0404 about 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. open up wiisports
2. toggle between no efb copy, efb to texture and efb to ram modes in dx9
plugin.
3.Observe quality

What is the expected output? What do you see instead?
no efb copy results in black square. That's to be expected. However, in efb
to texture, very little aliasing occurs. When efb to ram is used, the
facial features are there, but on the black square used in no efb copy, it
is very aliased and blurry. Why is that?

What version of the product are you using? On what operating system?
r4949

Please provide any additional information below.
look at the pics


Related issues

Is duplicate of Emulator - Emulator Issues #1891: EFB to RAM upscaling problemFixed

History

#2 Updated by marcel.werner3 about 10 years ago

hm, you have that "low res" only on that upper left square? when I enable EFB to RAM,
the whole screen is "low res" :-|

#4 Updated by kevinx0404 about 10 years ago

upper left square on efb to ram=low res crappy NOT normal
upper left square on efb to texture=pretty everywhere normal
upper left square on no efb copy=black square normal

#5 Updated by rodolfoosvaldobogado about 10 years ago

efb to ram uses the native resolution so is spected to be lowress this is not an
issue is totally normal

#6 Updated by kevinx0404 about 10 years ago

is it possible to render efb to ram at a higher resolution other than native? I have
more than enough performance to throw at this emulator.

#7 Updated by rodolfoosvaldobogado about 10 years ago

no is not posible, the memory reserver for the texture is not determined by the
plugins, is in the cpu and is determined by the game, so efb to ram needs to work in
native resolution

#8 Updated by kevinx0404 about 10 years ago

I guess I'll be sticking to efb to texture then.

#9 Updated by jayork42 about 10 years ago

If you are using DX9 upscaling, it will appear clearer.

#10 Updated by jayork42 about 10 years ago

This appears to be the same issue as issue 2003.

#11 Updated by sl1nk3.s about 10 years ago

  • Status changed from New to Questionable

it's actually the same as issue 1891.

#12 Updated by sl1nk3.s about 10 years ago

  • Status changed from Questionable to Duplicate

#13 Updated by kevinx0404 about 10 years ago

hmm, so efb to ram shows how really crappy the wii graphics were? I haven't touched
my wii for months.

Also available in: Atom PDF