Project

General

Profile

Emulator Issues #2170

More missing textures

Added by justin.sweglar almost 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Hopefully this will help track down missing textures and issues in games.

This is just a list of pics with graphical issues. I believe the same
issues are on OGL(but I could be wrong)

Super Paper Mario(wii)
http://img40.imageshack.us/img40/711/r8pp0114.jpg
http://img35.imageshack.us/img35/8051/r8pp0115.jpg
http://img188.imageshack.us/img188/3543/r8pp0113.jpg
http://img188.imageshack.us/img188/2765/r8pp0112.jpg
This one you'll notice black scribble marks on the top left area. I believe
this is supposed to be a full screen effect, Also noticeable when at
flipside city entering homes. But the effect is different more of a spiral.
Probably some sort of a shader effect not working properly. Every door in
the game does not open correctly also causes huge lag every time you enter
one.
http://img12.imageshack.us/img12/3284/r8pp0111.jpg
In the desert you'll notice that the background image is stretched on both
sides and the heatwave effect is totally missing exp when the guy appears
it looks correct inside his box.
http://img35.imageshack.us/img35/4060/r8pp0110.jpg
http://img18.imageshack.us/img18/5792/r8pp019.jpg
http://img41.imageshack.us/img41/1039/r8pp018.jpg
http://img200.imageshack.us/img200/797/r8pp017.jpg
There's numerous parts in the game that have missing textures. This is the
first that I found the floor, although just before this stuff comes out of
the wall and drops down the hole is all invisible as well. Also Multi kills
on mobs is supposto have a graphic plus a boarder that grows every kill but
totally transparent.
http://img188.imageshack.us/img188/7465/r8pp015.jpg
http://img40.imageshack.us/img40/4975/r8pp014.jpg
http://img188.imageshack.us/img188/2892/r8pp013.jpg
http://img40.imageshack.us/img40/9601/r8pp012.jpg
This I believe is supposto cover the whole lvl but instead hovers in the
middle of the background.
http://img40.imageshack.us/img40/7725/r8pp011.jpg

Fire Emblem(game cube) Is the very beginning press any button(The
background is missing a texture that has some warning crap on it, This was
visible only in OGL on 4771, can't see any more on current builds in DX or OGL.
http://img686.imageshack.us/img686/1862/gfep012.jpg
This issue is only on DX the movable parts are not stretched correctly.
http://img686.imageshack.us/i/gfep014.jpg/

What version of the product are you using? On what operating system?
r4971, XP32, DX9 plugin


Related issues

Is duplicate of Emulator - Emulator Issues #360: Bounding Box registers are not working correctlyFixed

History

#1 Updated by darksonic_ds almost 10 years ago

About the graphics...that missing textures "fix" the super paper mario and TYD, fix
a problem with 3d.

#2 Updated by lessmasterdark almost 10 years ago

Some of the Super Paper Mario issues are bounding box errors (check issue 360).

#3 Updated by Anonymous almost 10 years ago

  • Status changed from New to Duplicate

Yup, check issue 360 and make another issue if any of this is not due to bounding box
registers.

Also available in: Atom PDF