Project

General

Profile

Emulator Issues #2213

Wii Menu does not show Channels

Added by thegamefreak0134 over 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Rip your NAND from a real Wii and copy the contents into the Wii folder
in Dolphin
2. From the Menu, Load the Wii Menu
3. Press A to get past the Anti-Lawsuit screen

What is the expected output? What do you see instead?
The expected output is the Wii Menu, basically exactly like it would look
on a real wii, with the Disc Channel top left and all the other installed
channels in the appropriate slots.

Instead, the Disc Channel (since it is not really a channel, but a feature
of the base menu) is the only channel that shows up. This is true both in
the Menu itself and in the Data Management screen. Likely this is due to a
missing or poorly implemented IOS call that the Wii Menu uses to read the
Wii's internal filesystem.

What version of the product are you using? On what operating system?
r5000 on Win7 64bit, RC. 64bit of Dolphin, behavior is identical with both
logic cores (Regular and IL)

Please provide any additional information below.
It doesn't seem to be a banner loading issue-- you can play a Wii game,
Stop it from the menu, then load the Wii Menu immediately after, and the
Wii Menu will happily recognize the disc and play its banner.

It would be nice to be able to launch channels from the Wii Menu directly,
as it would mean that we could play channels directly from our ripped NAND
without needing to first convert them to WAD format. Then again, does the
Wii Menu even support launching disks yet?

Oh: I scanned over the Issues looking for a duplicate of this, but did not
find one. If I was blind, I apologize deeply, and will repent and mourn my
losses for 7 days.


Related issues

Is duplicate of Emulator - Emulator Issues #661: Wii-Menu Problems: Address book, Memo, Game Booting, GC Disc Recognition, SettingsFixed

History

#1 Updated by thegamefreak0134 over 10 years ago

Oh, I forgot: I think this is using version 4.2U of the Wii Menu. I'm not terribly
sure, as the screen to check it (the settings screen) freezes, as noted in a separate
issue.

#2 Updated by Theevillightbulb over 10 years ago

But dumping your NAND does not dump the channels does it? AFAIK dumping your NAND
just gets you the wii menu... All the other channels are in the built in flash memory
and they are already wads if i remember right... I guess use a wad manager and you'll
see what I mean...

#3 Updated by lpfaint99 over 10 years ago

  • Status changed from New to Duplicate

NAND == flash memory

this issue is due to the incomplete ioctls for the wii (I believe)

no worrys about the duplicate, issue 661 is about this and other wiimenu issues, but
this is not listed in the description

#4 Updated by pascal.jouy about 10 years ago

I should add that using the "Change disc" option in Dolphin does not make the disc
appear in the Disc channel.
If the disc is loaded by using the Default ISO option, the Disc channel displays the
banner and you can normaly launch the game.

Also available in: Atom PDF