Project

General

Profile

Emulator Issues #2316

Widescreen Hack only "hacks" from 4:3 to 16:9

Added by Billiard26 over 10 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Currently, the "Widescreen Hack" option in the D3D plugin only works
correctly when playing a native 4:3 aspect ratio game on a 16:9 aspect
ratio display. The hack simply stretches the game aspect ratio from 4:3 to
16:9 regardless of the aspect ratio of the current window. When using the
hack, this causes 4:3 games to have an image that is too skinny on 16:10
displays. It is also completely non-functional on native 16:9 games.

It should be modified to be called "Aspect Ratio Hack". It should adjust
from the games native aspect ratio, either 4:3 or 16:9, this is already
detected correctly when using the "Auto" aspect ratio, so this isn't a
problem. And the aspect ratio should be "hacked" to that of the display,
4:3, 5:4, 16:9, 16:10, or anything.

History

#1 Updated by ayuanx over 10 years ago

  • Status changed from New to Questionable

......

#2 Updated by luisr142004 over 10 years ago

uuhh, the widescreen hack is supposed to include more of the game (and it works best
with the 16:9 option) >_>

#3 Updated by Anonymous over 10 years ago

  • Status changed from Questionable to Invalid

It does what is intended, which is to change the projection so that more geometry is shown.

#4 Updated by Billiard26 over 10 years ago

Yes, it does change the projection from a 4:3 to a 16:9 aspect ratio correctly, but
it should be changed depending on which aspect ratio the user is actually using, not
just 16:9 always.

#5 Updated by luisr142004 over 10 years ago

"not just 16:9 always."
um, that's why it's called "widescreen", (16:9 being widescreen usually) :p

#6 Updated by Billiard26 over 10 years ago

Yes, I understand widescreen is 16:9. I'm suggesting the hack be renamed "Aspect
Ratio Hack" and modified to work for all aspect ratios. The whole point of the hack
is to play games on an aspect ratio they were not designed for, why not make it
support more than just 16:9.

#7 Updated by luisr142004 over 10 years ago

well the point is that it's not an Aspect Ratio Hack >_>

Also available in: Atom PDF