Project

General

Profile

Emulator Issues #237

Sonic Heroes Controls Messed Up

Added by josh.lar.JL about 11 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Play Sonic Heroes as Sonic Tales & Knuckles (Although I think it affects
all modes of gameplay)
2. Play for a few and you will eventually notice that your character walks
extremely slowly, like as if you pressed an analog stick 10%
3. As a result you can't really keep playing because your player is too slow

What is the expected output? What do you see instead?
player walks unplayably slow...

I have seen this bug for a long time and it never got fixed so I just
thought I would bring it up


Related issues

Is duplicate of Emulator - Emulator Issues #960: Auto-fire / Control Stick ProblemFixed

History

#1 Updated by knuckles500 almost 11 years ago

I can confirm this too, but for Sonic Heroes, it depends on what stage you start on.

There's a similar issue with Sonic Adventure DX where using the analog stick to move
up or down doesn't work, but left and right works fine.

And I remember it working fine in earlier revisions as well.

#3 Updated by superempra almost 11 years ago

This happens to me too.

#4 Updated by XTra.KrazzY over 10 years ago

  • Status changed from New to Fixed

#5 Updated by DamentZ over 9 years ago

This defect is not fixed, nothing has changed. Sonic Heroes still is unplayable at
some points, especially in multiplayer.

#6 Updated by DimitriPilot3 almost 9 years ago

  • Status changed from Fixed to Duplicate

Also available in: Atom PDF