Project

General

Profile

Emulator Issues #2480

"Red Steel" not playable (Freeze)

Added by gabrielmorano over 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1.Load the iso
2.As soon as the iso loads the words "licensed by Nintendo" will appear and
you will notice the game freeze's right there

What is the expected output? What do you see instead?
There is no possible combination (neither on the emulator, nor d3d or
opengl) that makes this game run.
Also reporting that "red steel 2" now loads

What version of the product are you using? On what operating system?
r5248 x64 x32
Intel(R) Core2Duo 2.53 2gb
GeForce 8400 gt 512
windows 7 x64


Related issues

Is duplicate of Emulator - Emulator Issues #661: Wii-Menu Problems: Address book, Memo, Game Booting, GC Disc Recognition, SettingsFixed

History

#1 Updated by brandon.hk.wong over 10 years ago

ah, this happened to me, u need to change the sysconf file or something, only thing is
that it doesn't guarantee a stable game, it still crashes for me at random places

kinda like Wii Sports Resort, however, that issue is APPARANTLY because the latest
revisions removed the Optimiize Quantizers option which, if disabled, will make the two
games work :S

#2 Updated by gabrielmorano over 10 years ago

"Red still 2" work, it's red still 1 the only that has the freeze, and i don't know
what you want me to change in the sysvonf, but this is still an issue since it does
not work properly on the emulator :S

#3 Updated by gabrielmorano about 10 years ago

Game still does not work on r6025 (im reporting this cuz some games where fixed)

#4 Updated by skidau almost 10 years ago

  • Status changed from New to Duplicate

Red Steel has the ES_LAUNCH problem (same as the Wii Menu). Check issue 661 for updates.

#5 Updated by gabrielmorano over 9 years ago

Im re opening this Issue as now the game boots (with some errors) but the game gets stuck at the begining... for another different reason :S
I think that the game could possibly work with LLE sound because this very same thing happened with RE Darkside Chronicles Before the fix. (but i can't test it)

here is a video of what happens (with the error messages on screen, except for when it gets stuck because there is no message shown when that happens)
http://www.youtube.com/watch?v=mx5kGL6yQ54

Here is a video to compare (this is how it should work)
http://www.youtube.com/watch?v=7pqZA3aLAgY&feature=related

#6 Updated by gabrielmorano over 9 years ago

Ok using a save i downloaded as a .bin and importing it to the emulator i noticed another issue

the savefile i dowenloaded is set on an advance place of the game, so i tried to test if the game gets stuck in another place as in the begining
But right from the start I noticed that you cannot move or do any actions (besides looking around) at all
you can't fire, you can't draw your sword, you cannot walk... you can't do a single thing but look.
also there is a complete abscense of sound

http://www.youtube.com/watch?v=U_ktCKduwhQ

Also available in: Atom PDF