Project

General

Profile

Emulator Issues #2528

The Legend of Zelda: Twilight Princess aim target problem in Direct3D9

Added by DemonicOne about 11 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Set graphics plug-in to Direct3D9
2. Start the game, new file, move into the game up to the moment you can
get a slingshot.
2a.(Optional) Set in game options pointer to off.
3. Try to fire it somewhere (medium distance) wall etc.
4. The spark from the impact will be greatly off about 20-30m.
5. Save the state shift+F1.
6. Change graphics plug-in to OpenGL.
7. Load F1, try to hit something.

What is the expected output?
Both OpenGL/Direct3D9 same aim, same target hit.

What do you see instead?
The ball from the slingshot when using Direct3D9 doesn't go where its
suppose to go, but goes as aimed with OpenGL.

What version of the product are you using? On what operating system?
Windows 7 x64, tried v2.0 RC1 and Orleans r5152

Please provide any additional information below.
Standing near a wall exaggerates the problem.
This bug can also affect boomerang range/moving targets lock ability.

This issue is game specific but it could affect other games as well.


Related issues

Is duplicate of Emulator - Emulator Issues #7128: Widescreen Hack Currently Performs PoorlyAccepted

History

#1 Updated by luisr142004 about 11 years ago

try changing the IR pointer settings in the wiimote plugin

#2 Updated by DemonicOne about 11 years ago

nope no effect
I'm using Logitech ChillStream (Xbox like pad) not a Wiimote if that helps.

#3 Updated by Anonymous about 11 years ago

...and if you leave the onscreen pointer on, where does the pointer show up?

#4 Updated by DemonicOne about 11 years ago

well there's no difference between with pointer and without
here are some screens, that present the difference between Direct3D9 and OpenGL I'm
talking about:
album: http://img13.imageshack.us/gal.php?g=badlw.png
OpenGL the spark is at the aiming cursor:
http://img243.imageshack.us/img243/1121/good.png
Direct3D9 the impact spark is not at the aiming cursor:
http://img13.imageshack.us/img13/8633/badlw.png

#5 Updated by DemonicOne about 11 years ago

just tested 2.0 release the bug is there too

#6 Updated by Anonymous over 10 years ago

  • Status changed from New to Questionable

does this still happen? looks like video bug (efb something or other?), nothing to do with wiimote.

#7 Updated by Billiard26 over 10 years ago

Do you experience the issue with "Widescreen hack" off?

I only have this problem when using widescreen hack, which is acceptable. :p

#8 Updated by Anonymous over 10 years ago

  • Status changed from Questionable to Invalid

ahh that would explain it :)

#9 Updated by DemonicOne over 10 years ago

well I just tested it and the aim is still off.

widescreen hack is off in both cases OpenGL and Direct3D9

#10 Updated by Billiard26 over 10 years ago

Enable CPU->EFB access.

#11 Updated by DemonicOne over 10 years ago

nope it was Enabled already.

#12 Updated by ms.geburt almost 10 years ago

did the trick for me, thanks :)

#13 Updated by MayImilae about 7 years ago

  • Status changed from Invalid to Duplicate

Also available in: Atom PDF