Project

General

Profile

Emulator Issues #2577

Metroid Prime 2 Echoes Bonus Disc (U) (P2ME01)-Unhandled case in write handler

Added by kolano almost 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Start Metroid Prime 2 Echoes Bonus Disc (U) (P2ME01)
2. Select Trailer from the menu
3. Dolphin produces a set of warnings and then crashes.

What is the expected output?
Trailer for Metroid Prime 2:Echos.

What do you see instead?
"Unhandled case in write handler!
Please implement of avoid"

"BackPatch - failed to disassemble MOV instruction

Error encountered accessing emulated address 02000000.
Culprit instruction:
mov byte ptr ds:[rbx+rdx], cl
at 000000000167afb3e"

"BackPatch: Currently only supporting reads.

Attempted to write to 02000000."

Then Dolphin crashes.

What version of the product are you using? On what operating system?
r5286 x64 Windows 7

Please provide any additional information below.


Related issues

Is duplicate of Emulator - Emulator Issues #233: Games that use multiple executables don't load (Sonic Gems Collection, Zelda Collection, demo discs, etc)Fixed

History

#1 Updated by Anonymous almost 10 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF