Project

General

Profile

Emulator Issues #2712

Twilight Princess (Gamecube) + Widescreen hack (DX9)

Added by Porgos almost 11 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Use the widescreen hack with Twilight Princess GC version.
2. Go to a place where water translucency is used.

What is the expected output? What do you see instead?

When the water is rendered in the area where the black borders should have
been, the shading seems stretched.

What version of the product are you using? On what operating system?

Using R5472, this problem was always there since the widescreen hack was
added. Using Windows 7 x64 Ultimate, on a mobility Radeon 4650, driver
version 8.740.0.0 (Catalyst 10.4)

Please provide any additional information below.

This is one bug that always existed: effects like water translucency in
Twilight Princess (GC) using the widescreen hack seem stretched in the area
that the screen extends to. Does that have to do with the widescreen hack
rather than shader rendering in the plugin? It's been around so long I'm
starting to think it can't be resolved... I could simply play the Wii
version that has a native 16:9 mode, but that version doesn't have controls
such as camera controlling with the secondary stick. The GC version plays
much better with a controller rather than the Wii version, even if you can
assign wiimote buttons to a controller.


Related issues

Is duplicate of Emulator - Emulator Issues #7128: Widescreen Hack Currently Performs PoorlyAccepted

History

#1 Updated by Billiard26 almost 11 years ago

Widescreen hack is a "hack". It isn't going to work perfectly for all games.

#2 Updated by Porgos almost 11 years ago

Of course it won't, but what if it can be improved?

#3 Updated by NeoBrainX over 10 years ago

  • Status changed from New to Invalid

Nope.

#4 Updated by MayImilae about 7 years ago

  • Status changed from Invalid to Duplicate

Also available in: Atom PDF