Project

General

Profile

Emulator Issues #2837

Direct X 11 fails to get past title screen

Added by tianeloso over 9 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1.Useing this plugin
2.trying to get past the title screen
What is the expected output? What do you see instead?
to get into menu. When i press start the screen goes black and shows errors
Dolphin version with the problem? Other Dolphin version without the
problem?All versions with this plugin

32-bit or 64-bit and any other build parameters?
64 bit

OS version and versions of tools/libraries used?
Windows Vista X64,dx 11 plugin

Processor: Intel(R)Core(TM)2 Duo CPU T5550 @1.83GHz 1.83Ghz

Memory (RAM): 4.00 GB

System Type: 64 bit operating system

Graphics card: NVIDIA GeForce 8800M GTS

Please provide any additional information below.

History

#1 Updated by tianeloso over 9 years ago

there was about 3 more errors than a crash but i thought this was enough =)

#2 Updated by aavindraa over 9 years ago

You have Windows 64bit but are using 32 bit? Try the 64 bit of the latest build:

http://www.dolphin-emulator.com/download.html

#3 Updated by Ignacio.Farias over 9 years ago

he is alrady using a 64 bit OS. Maybe the problem is with windows vista, couse it hasn't dx11. Only windows 7 have it. (btw, sorry for my poor english)

#4 Updated by YarnovaScape over 9 years ago

I'm having the same problem.
OS: Windows Vista Home Premium - Service Pack 2
Processor: Intel(R) Core(TM) 2 Quad CPU Q8200 @ 2.33GHz 2.34GHz
Memory (RAM): 8.00 GB
System type: 64-bit Operating System
Graphics card: NVIDIA GeForce GT 120

#5 Updated by kevinx0404 over 9 years ago

windows vista has dx11 too.

#6 Updated by LexLight5 over 9 years ago

No, Kevin, Windows Vista has DX10, not DX11.

#7 Updated by NeoBrainX over 9 years ago

Do you compile builds yourself or using precompiled ones?

btw, if he didn't have DX11 installed he couldn't even select the plugin. AFAIK Windows Vista received DX11 support through a Windows Update.

#8 Updated by tianeloso over 9 years ago

Must be vista then. I tried the plugin on my buds laptop running windows 7 and it worked perfectly. I will be on a look for an update. thanks anyway

#9 Updated by NeoBrainX over 9 years ago

  • Category set to gfx
  • Issue type set to Bug

Nah, I might know how to fix it, I'd just need to check whether you gfx card supports B8G8R8A8 textures :/
Vista is totally fine, especially since you already managed to run the plugin up to that point...

#10 Updated by MKmaster over 9 years ago

For all those shouting "Vista! Vista!", let me discourage you.
I own an 8600GT on a Windows 7 Ultimate edition and am encountering the same errors.
So it most likely is as NeoBrainX just stated in the comment above this one.

#11 Updated by NeoBrainX over 9 years ago

  • Status changed from New to Fixed

Should be fixed in r5743.

#12 Updated by crazysheep17 over 6 years ago

This still occurs on my Windows 8x64 nvidia 660m intel 3630QM. Same issue as 5965. All versions through the current 3.5-1406.

Also available in: Atom PDF