Project

General

Profile

Emulator Issues #2838

Metroid prime trilogy green screen video

Added by Ignacio.Farias almost 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1.using any plugin
2.Play metroid prime trilogy

What is the expected output? What do you see instead?
Besides of the wrong colors of the game, when you supose to start playing, the screen freezes with metroid prime logo (dx11 plugin) and with dx9 plugin, the screen freezes with black screen. It's suposed that the game should start after that "loading screen?"

Dolphin version with the problem? Other Dolphin version without the
problem?
r5732

32-bit or 64-bit and any other build parameters?
64 bit edition, and any plugin, i.e, dx11 and dx9 plugins

OS version and versions of tools/libraries used?
Windows 7 x64

Please provide any additional information below.
Phenom 22 x4 b55@3.8ghz
xfx 5770


Related issues

Is duplicate of Emulator - Emulator Issues #661: Wii-Menu Problems: Address book, Memo, Game Booting, GC Disc Recognition, SettingsFixed

History

#1 Updated by marcel.werner3 almost 10 years ago

Known issues already...
I think the green screen is fixed by enabling Safe Texture Cache.
The game freezing when trying to load one of the three games is because multiple .dol-files are still not supported...

#2 Updated by Ignacio.Farias almost 10 years ago

oo sorry marcel, didn't mean to post already known issues, i'll mak sur for next time to search first. And again, sorry :)

#3 Updated by NeoBrainX almost 10 years ago

  • Status changed from New to Duplicate

#4 Updated by skidau almost 10 years ago

Metroid Prime Trilogy uses IOCTL_ES_LAUNCH to boot up the games. It is a duplicate of issue 661.

Also available in: Atom PDF