Project

General

Profile

Emulator Issues #2894

metroid prime 2 echoes : cannot scan alien coded doors with dx9 plugin.

Added by vasishath about 10 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. in mp2 , try scanning alien doors with dx9 plugin.

expexted scan sequence. but no action !

my dolphin rev is 5821 x64 on windows 7 x64.

as i have intel X45MHD gfx , so i cant use opengl.
plz help. dx 11 causes many graphical glitches in he game.


Related issues

Has duplicate Emulator - Emulator Issues #4070: Metroid Prime 2 PAL: certain unscannable objectsDuplicate

History

#1 Updated by marcel.werner3 about 10 years ago

I think I had the same issue in Metroid 3 in the human base at the beginning...

#2 Updated by nurimep about 10 years ago

uh, change the efb options and you'll succeed

#3 Updated by vasishath about 10 years ago

its no use. changing efb disables the scanner. i am talking particulary about alien doors. otherwise scanner works ok eith efb to ram.

#4 Updated by skidau almost 10 years ago

  • Category set to gfx

#5 Updated by vasishath almost 10 years ago

hey ! just wanted to update the status of this issue. As i am using intel x4500mhd gfx card , i was not able to use opengl plugin. But now , after an driver update , i am able to use the opengl plugin. But still , i am not able to scan the doors and many items like the spaceship etc. I would like to tell here that am using the PAL version of the iso. Anyone got a solution ??
Thankx.

#6 Updated by skidau over 9 years ago

issue 4070 has been merged into this issue.

#7 Updated by Randay_xd over 9 years ago

wow, this is exactly like the issue i posted (issue 4070)
I tried every single thing from enabling texture to ram to safe cache,
no solution worked for me. hopefully there is a fix to this problem.

#8 Updated by vasishath over 9 years ago

the issue is with the dx9 plugins. opengl works perfect on scanning. but if you are still not able to scan ( like me ) then its a gfx card problem. my intel gma does not have proper support for opengl 2.1. the proprietary drivers are not good enough. i think your card is also the same. well i have found a solution for this. if you can install ubuntu on your pc , then try dolphin on ubuntu. ubuntu uses open source drivers for the card which are , surprisingly, WAY BETTER than the proprietary drivers. in linux , i was able to scan everything in mp2 without any issues. if you can, try the ubuntu 11.04 natty which is in alpha stages right now. but it will give you better graphics than 10.10 ( as the open source drivers found in 10.10 dont support 1 or 2 extensions which leads to some random lines and glitches in the game but you will be able to scan perfectly though ).
cheers !

#9 Updated by rafiel_lol over 9 years ago

i am using r7482 with intel 4500mhd gfx card too, directx 11 plugin works for me. I was able to scan allien doors with the settings recommendated for the game.

#10 Updated by bruno.serafim58 almost 9 years ago

Isn't this fixed? I couldn't scan the ship or alien coded doors in past revisions, but since 7700 or so it works perfectly fine.

#11 Updated by skidau almost 9 years ago

Did you test it with the DX9 plugin?

#12 Updated by bruno.serafim58 almost 9 years ago

Yep, DX9. I even gave up playing due to that issue, but decided to give it a try with the latest revs and its working fine.

#13 Updated by skidau almost 9 years ago

  • Status changed from New to Fixed

#14 Updated by coolitic almost 9 years ago

You must have EFB copies to RAM and not texture

#15 Updated by sqykly over 8 years ago

I gave up on this game after getting to the first boss using DX9. In addition to all settings mentioned above, I had to un-check "disable per-pixel depth" to get the scanner to work at all, which more or less makes sense, since the game is trying to highlight the scannable objects by pixel. However, as noted above, the alien doors, the ship, the cryo-capsules, and some corpses were highlighted but not scannable. Using every possible configuration with the OpenGL plugin, I was unable to get anything but flickering solid colors on the scanner, and it did not function at all. I am serious, I tried every possible configuration, brute force. Using DX11 with the same settings that worked with DX9, all objects that were NOT scannable with DX9 became scannable! Unfortunately, many other objects that WERE scannable in DX9 became un-scannable with DX11. Specifically, attempting to scan the transparent tubes running from the save point before the first boss, and more importantly, all elevator controls, had no effect at all. These objects were highlighted (yellow and red) but could not be locked onto. For other objects that were scannable in DX9 but not in DX11, the scanner would recognize the object as scannable, but upon pressing 'L', a different object in the same room would be instantly turned to and scanned instead. This included the cocoon on the ceiling that contains the first boss (which instead scanned a normal door), the alien met right after the first boss (which instead scanned the machine behind him, regardless of the angle I scanned him from), and one of the floating energy enemies first encountered immediately after passing through the first alien door that could be opened (which instead scanned the door I came through). Only one of the aforementioned floating energy enemies was affected - the others were scannable. I was unable to progress beyond that point because neither DX9 nor DX11 supported the scanning of both alien doors and elevator controls. I reiterate that with OpenGL the scanner showed only garbage (random flashing solid colors that could not be locked onto) with all possible configurations (and crashed with several of them).

My system has integrated Intel HD graphics and dual-core Pentium B950. It seems to work perfectly well for almost all other GC games I've tried. The Dolphin I'm using was compiled Dec 29 2011.

#16 Updated by sqykly over 8 years ago

Updated Dolphin to 3.0-397 (most recent as of 2/1/2012) and it has precisely the same combination of problems with all graphics backends, plus additional random garbage pixels with OpenGL, and a noticeable performance drop with all three. I only tested the OpenGL settings that partially worked with DX9 & DX11 this time.

#17 Updated by aguirre.joel over 8 years ago

Well, i have a core i5, 1TB,6GB RAM PC with intel HD Graphics and i'm playing MP2, i tried to do this: play with directx9 to scan the things that i can't scan with directx11, then save the game and start it with directx11 to scan other things. I was useful until i defeat amorphis (dark suit). In the elevator to Turian(i don't remember exactly) i can't activate it by scanning. The problem is that i can't use the method i was using because i need directx11 to scan the alien doors and directx9 to scan the elevator and activate it, however there is not a save point after returning form the dark world (where you activate a kind of "train" just because in the light world you need super misile to open the door). i don't know if metroid prime has the same issue but i would like to play metroid prime until someone finds a solution to the scanner in metroid prime 2. Please if someone found the solution share with us. :D

#18 Updated by skidau over 8 years ago

From the reports, it's looking like a bug in the Intel graphics driver. Maybe open an issue report with Intel.

#19 Updated by oxwar88 over 8 years ago

when I wing door to go to trovus will not let me scan it and therefore will not let me get inside

#20 Updated by tommylube about 7 years ago

I am on a mac on the latest revision of Dolphin as well, and also experience this issue. Will try and modify EFB settings and see what's good.

#21 Updated by corruptsecrets about 6 years ago

I had DX9, and some items were unscannable, and then I got DX11, and the scannable and unscannable items swapped! However, when I attempt the Item Loss Glitch, the scannable items switch back to DX9 configuration.

#22 Updated by FrYoonHo over 5 years ago

I'm having the same issue eventhough I'm playing with the latest version (4.0). Even changing efb and setting to OpenGL doesn't do anything about this problem and it's driving me nuts!! And because of that, I can't proceed after beating the first boss.

#23 Updated by pedro.nejelski about 5 years ago

Hello guys, I was having the same issue with some other RED objects on the visor, which didn't scan, but it happened after I change the enhancements Anisotropic filtering and Anti-Aliasing, so I guessed and removed them, and it worked fine for me, I'm using D3D on Dolphin 5.0 RC, but also had this on 4.0 6860 (the last I used).

Also available in: Atom PDF