Project

General

Profile

Emulator Issues #2913

Issues with DX9 framedumping utility

Added by jayork42 about 10 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Start a GC/Wii game with the DX9 plugin and begin dumping frames
2. Results are problematic, but vary depending on settings. More details in additional info.

What is the expected output? What do you see instead?
The dumper is expected to record at full speed at the correct resolution.

Dolphin version with the problem? Other Dolphin version without the
problem? R5844, this was working fine before but again, I haven't tested in several hundred revisions.

32-bit or 64-bit and any other build parameters?
32

OS version and versions of tools/libraries used?
Windows XP Pro MCE x86

Please provide any additional information below.

I've noticed several different overall problems with the DX9 framedumper. With render to main window off, the end video is a lower resolution and a slightly greater aspect ratio than the window setting. For example, when the window resolution is 640x480 with an aspect ratio of 1.33, I get 632x446 with a ratio of 1.42 in the video. With 800x600 1.33 I get 792x566 1.39, and so on. This is not a problem in fullscreen.

With render to main window enabled, if I scale the window larger or smaller and dump frames, Dolphin crashes. This only works if I don't touch the default window size, which doesn't change if I choose a different resolution, and also remains constant in the recorded videos.

I've also had games to slow down to about 2fps with 100% CPU usage when dumping with the widescreen hack, but now I can't reproduce the problem.

If I find anything else I'll update the issue.

History

#1 Updated by jayork42 about 10 years ago

The window scaling problem does happen with the seperate render window as well.

#2 Updated by rodolfoosvaldobogado about 10 years ago

could you test with my last commit?

#3 Updated by Anonymous about 9 years ago

  • Status changed from New to Won't fix

noresponse

Also available in: Atom PDF