Project

General

Profile

Emulator Issues #2917

Poképark Wii - Perpetual loading (ingame)

Added by Rupeeclock over 9 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Load Poképark Wii, create a gamesave and start a new game
2. The intro video plays
3. The game displays a loading screen

What is the expected output? What do you see instead?
The game should load and gameplay should begin. The first thing you should see is an introductory dialogue from Mew.
Instead, the loading screen never progresses, with an animation of Pikachu falling perpetually.

Dolphin version with the problem? Other Dolphin version without the
problem?
r5847

32-bit or 64-bit and any other build parameters?
32bit

OS version and versions of tools/libraries used?
Windows 7 32bit

Please provide any additional information below.
This is tested using a European copy of the game, extracted from a retail disc.
Issue persists in JIT and JITIL recompilers.


Related issues

Has duplicate Emulator - Emulator Issues #3506: Pokepark prefix 02 error 0x024000E0Duplicate

Has duplicate Emulator - Emulator Issues #4170: PokePark hungs after intro while displaying Loading...Duplicate

Has duplicate Emulator - Emulator Issues #5073: Problem Pikachu Pokepark WiiDuplicate

History

#1 Updated by sheng.long200x over 9 years ago

Ah, The pika STILL hasn't stopped falling.

Saves me a download. Will someone figure out why that Pikachu can't stop falling, before a Skitty or a Meowth uses the fact to catch it quicker?

#2 Updated by Rupeeclock over 9 years ago

sheng.long, Dolphin-emu does not approve of anyone illegally downloading Wii games.

#3 Updated by Rupeeclock over 9 years ago

Okay, I'm mostly just an end-user, but I decided to take a look at the log files for Dolphin.
Attached is my log file, the conditions being:
- Brand new Log File
- Brand new Gamesave on poképark Wii
- Starting a new game, playing intro video, watching loading screen, stopping emulation.

In particular, there's some interesting lines I want to take note of:
Line 63: 45:15:015 .\Src\IPC_HLE\WII_IPC_HLE_Device_FileIO.cpp:115 W[WII_IPC_FILEIO]: FileIO: Open failed - File doesn't exist ./User/Wii/title/00010000/52384150/data/GWD
Lines 63 through 72 are similar, all starting that these save files don't exist. However, they do, they are in the folder.

Even more curious is this line.
Line 53: 45:02:866 .\Src\IPC_HLE\WII_IPC_HLE_Device_FileIO.cpp:115 W[WII_IPC_FILEIO]: FileIO: Open failed - File doesn't exist ./User/Wii/tmp/Pokemon/Res00.dan
Lines 53 through 58 indicate the presence of temporary files created on the Wii's memory, these 5 files take up 38mb. I have emulated many Wii games and not seen any others create temporary files like this before.

When opening one of these Temporary files (Res03.dan) in Notepad++, there are many references to .efb and .brres files, including: EfPigeon.efb, EfPikachu.efb, EfSamehader.efb, Pigeon.brres, Pikachu.brres, and other things.

I'm not a programmer, but as an end-user I would have to guess that on real hardware, Poképark Wii for whatever reason stores temporary files on the Wii, and then accesses these temporary files for EFB access and sound effects.

If it is of any help to the programmers I have also attached a one of the temporary files, Res03.Dan.

#4 Updated by justjamjam over 9 years ago

i really wanna play this game can someone fix this issue already

#5 Updated by Rupeeclock over 9 years ago

Me too, I want to be able to play-test the game for Dolphin.
I can't imagine this loading issue would be too difficult to fix, I think it's mostly related to the 38mb of temporary files it creates.

#6 Updated by justjamjam over 9 years ago

well if its that simple i guess it shouldn't take them long to fix i just hope they finally fix this issue soon coz i'm growing restless

#7 Updated by james_wilson_ over 9 years ago

Have you tried it with LLE? I know that it won't be playable, but it would be an interesting experiment.

#8 Updated by Rupeeclock over 9 years ago

The issue persists with the LLE plugin, and I don't believe the issue is related to the sound emulation in any way.

The plugin seems to work well, aside from the video on the title screen.

#9 Updated by Rupeeclock over 9 years ago

I've something to add to the issue.
Using a gamesave that has an attraction unlocked, thus playable in the arcade without loading a saveslot, trying to play one of these attractions results in a black screen.
On the black screen you can still access the Home menu.

I can't however provide a gamesave as it is 12mb.

#10 Updated by justjamjam over 9 years ago

hmm i was thinking since you could just extract the necessary files from the game with dolphin via game properties could you most likely get dolphin to read the needed files from a directory i dunno something like that....

#11 Updated by Rupeeclock over 9 years ago

The issue has advanced with r6164
The game now attempts to get past the loading screen and then crashes.

Unknown pointed address prefix 62, report this to the devs: 0x62875A20

#12 Updated by skidau over 9 years ago

issue 3506 has been merged into this issue.

#13 Updated by meseary2004 over 9 years ago

so has anyone figured it out yet?

#14 Updated by Rupeeclock about 9 years ago

The issue has changed, giving a different error message.
On Dolphin r6746, the game gives two error messages at the same point, "DSI exception in stmw", and then "DSI exception in lmw" or possibly "Imw"
That's when using JIT.

#15 Updated by skidau about 9 years ago

issue 4170 has been merged into this issue.

#16 Updated by christoph.korn about 9 years ago

Can you please provide some information about the background and complexity of this to fix?
Is it only a bug in existing code or is functionality missing in order to make the game run?

I am mainly an user but willing to help to fix this bug.

#17 Updated by christoph.korn about 9 years ago

Thanks to the help of the people in the IRC channel we were able to analyze the problem a bit:
http://pastebin.com/Kr7PbM3J

This is the backtrace I got with the "core" file of the crash.
On Ubuntu I had the libc6-dbg package for debugging symbols installed.

With the interpreter the screen just was black at the time when normally the crash occured.
It looks like it was trapped in an infinite loop:
http://img6.imagebanana.com/img/pxyv87eu/Auswahl_007.png

#18 Updated by skidau about 9 years ago

Usually a game would go into an infinite loop if it has spun off another thread (which is meant to do the work) or if it has detected an error condition.

#19 Updated by christoph.korn about 9 years ago

Well I ran the game in the debugger and got to the point where the game normally crashed. But this time Pikachu just keeps falling forever without crashing the game. The game seems to be in some different infinite loop than on my screenshot because when this (from comment #18) loop happened there was just a black screen.
However after stopping the game and trying again the game also crashed now. So it is not behaving always the same. To be honest I have no idea what to look at in the debugger anyway.
Seems without proper debugging skills or code knowledge I won't get far with this bug.

But with the source code I have the same problem that I do not know where to start looking at.

Could someone give me a tip about in which module this bug might occur from ?

I also don't understand why I don't get a good backtrace from gdb although debugging symbols of a required library have been loaded:
Reading symbols from /lib64/ld-linux-x86-64.so.2...Reading symbols from /usr/lib/debug/lib/ld-2.12.1.so...done.
done.
Loaded symbols for /lib64/ld-linux-x86-64.so.2

#7 0x00007f866b164040 in ?? () from /lib64/ld-linux-x86-64.so.2

#20 Updated by isaacandrews123 over 8 years ago

if you load a save from after the intro.... it works

#21 Updated by carlos.ismael.braz over 8 years ago

where did you get that save?

#22 Updated by Rupeeclock over 8 years ago

Isaac, which version of Dolphin is the game working in for you?
I have a completed save loaded from my wii and the game still crashes when trying to load the playable game, regardless of the intro video.

#23 Updated by Anonymous over 8 years ago

so far I've narrowed it down to:
801D16D4 lwz r10, 0(r5) # becomes 0
this occurs in what appears to be the processing of WAV (and other?) assets in MEM2. After the nullpointer is seen, some garbage processing occurs, and eventually a read from a bad address happens, causing a DSI exception. The game dies in the unhandled exception handler. Removing the DSI here doesn't help, since the real problem is whatever causes the value at 0(r5)(8049a394) to be 0. :<

osreport is at 802098E0

#24 Updated by Anonymous over 8 years ago

issue 5073 has been merged into this issue.

#25 Updated by Rupeeclock about 8 years ago

Poképark 2 reportedly has the same loading issues as the first game did, going by forum activity.
http://forums.dolphin-emulator.com/showthread.php?tid=5581&page=3

#27 Updated by parlane about 8 years ago

This issue was closed by revision 095b9de85e41.

#28 Updated by parlane about 8 years ago

This issue was closed by revision 53d2d9718fe3.

Also available in: Atom PDF