Project

General

Profile

Emulator Issues #2979

Optimize Quantizers Option needs to be re-implemented

Added by frosty5689 almost 10 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Having optimize quantizers on by default is an issue for some games
2. Fire Emblem Path of Radiance for example will experience clippy audio with the option enabled

What is the expected output? What do you see instead?
Sound is abnormal

Dolphin version with the problem? Other Dolphin version without the
problem?
r5985

32-bit or 64-bit and any other build parameters?
32bit and 64bit

OS version and versions of tools/libraries used?
Windows 7 Ultimate

Please provide any additional information below.
If possible, please re-enable the option to turn off optimize quantizers, it creates minor defects in some games. The one that i'm sure of is Fire Emblem Path of Radiance, the sound gets clippy with optimize quantizers on. Fixing the issue completely would be good too. Thanks

History

#1 Updated by Xtreme2damax almost 10 years ago

No, the new implementation is stable enough to be on by default and not require an option, let's not bloat the interface with even more unnecessary options. If the quantizers by some weird almost impossible chance causes issues with sound, then I'd rather them fix the bug than add this option back in.

For now you should review the DSP commits and ensure none of the DSP commits are responsible for your issue, I am still quite certain that no games would be using these instructions for sound, since quantizers mostly affects the core. It would just be weird for this to affect a single game, and so far no one else has been reporting any sound issues with the quantizers so that itself says a lot.

#2 Updated by Xtreme2damax almost 10 years ago

Well it affects the core, which also created some issues with graphics in the past due to incorrect logic or something. So far until now, there hasn't been any sound issues reported with the quantizers.

#3 Updated by luisr142004 almost 10 years ago

  • Status changed from New to Questionable

#4 Updated by frosty5689 almost 10 years ago

If you look up fire emblem path of radiance and dolphin, when the option to disable optimize quantizers was available, turning it off fixed the audio issues. I don't know why it did what it did, but it is causing it. Try it yourself if you must.

#5 Updated by giaga7 almost 10 years ago

Excuse me, but why don't add it only in game properties?:) By default it's always on and only for some games you can put it off by game properties!;)

#6 Updated by Xtreme2damax almost 10 years ago

Because an option isn't needed anymore, the safe quantizers are stable enough not to need an option. Back when the old quantizers method was used I would have agreed that the option was needed, but not now.

The issue has already been reported, once the developers confirm the issue they'll get around to fixing it in due time. No sense re-adding the option when they can just fix the issues and avoid re-adding the option. The sound can't be that bad, at least nor bad enough to hinder gameplay like the old quantizers method did in the past.

#7 Updated by BhaaL almost 10 years ago

r6114 introduced changes to quantizers, can anyone try if this fixes things?

#8 Updated by daxtsu almost 10 years ago

Audio is still crackly in the movie cutscenes in FE:Path of Radiance in 6114, at least for me.

#9 Updated by BhaaL almost 10 years ago

Crackling audio is not related to Quantizers.

#10 Updated by frosty5689 over 9 years ago

It was causing crackling noises when the optimized quantizer option was available and turned on. Now that its on by default, its always crackling and tweaking the audio plugin settings doesn't help.

#11 Updated by Xtreme2damax over 9 years ago

It isn't related to quantizers, another commit caused the crackling issue and it's not known yet what commit caused this issue. You heard it from the mouth of a developer that just commented above you, the issue is not related to quantizers as the current crackling issue is a recent issue that is related to the Dsound backend. Several games have crackling issues with the Dsound backend so use the OpenAL backend for right now until the developers fix the issue with the Dsound backend. Audio is more clear with the OpenAL backend with little to no crackling from what I've tested so far.

There doesn't need to be an option as quantizers aren't the issue here, the code for quantizers is actually quite stable now. This is strictly an issue with the audio plugin and backend, there's still a lot of work yet that needs to be done on DSP emulation and issues with the audio backend that need to be fixed.

Crackling was never an issue before even with quantizers enabled, so find the dsp commit that caused the issue and let us know once you find the dsp commit that caused the issue.

Jack Frost wouldn't have bothered to respond if he wasn't sure that quantizers isn't the issue, I'm sure he might know what commit caused the crackling issue.

#12 Updated by BhaaL over 9 years ago

I don't know the exact revision, but quantizers can't possibly affect it - the DSP and the Jit do not share any data.
The only exception would be DMA transfers when the CPU (Jit) uploads new data to the DSP; and even that should not be affected by quantizers (since the DSP does the work on the data, the CPU only provides it raw).

However, we can try to find the problem if someone goes and finds the exact revision.

#13 Updated by Xtreme2damax over 9 years ago

@Jack Frost, sound is more clean and clear with the OpenAL backend than the Dsound backend, the difference can be observed with the LLE plugin even.

I believe part of the issue may be related to the audio backend, especially with the HLE plugin although the Dsound backend with the LLE plugin has the same issue. OpenAL with LLE is crystal clear though compared to Dsound, the only issue with OpenAL is that the audio skips due to trying to stay in sync with the video as there is no audio smoothing implemented into the OpenAL backend and the LLE plugin. Crackly audio exists with both the Dsound and OpenAL backend with the HLE plugin but it's less noticeable with the OpenAL backend.

#14 Updated by jaitsu over 9 years ago

The quantizers don't just affect this game. Another game they affect is Star Fox Assault - see bug 4 at http://forums.ngemu.com/dolphin-discussion/116611-gcn-starfox-assault-official-thread.html

Evidently the only known fix for this is disabling the quantizers, which is now impossible with newer revisions which are missing the option. Having to go back to an old version of the emulator to get a relatively mainstream game working because an option has been removed doesn't make a lot of sense.

#15 Updated by Xtreme2damax over 9 years ago

It's pointless to add an option back that only affects a couple games. Open an issue on the issue tracker, and hopefully a developer will look into and fix the issue negating the need to add the option.

The only reason it was optional in the past, was when the "unsafe" quantizer code was implemented and several games were affected. The option has since been removed with the improved safe quantizer code, and now only a couple minor issues with a couple games remain.

Crackling in ToS was unrelated to quantizers and that issue was recently fixed as far as I know. So really only one game is affected by quantizers, not really worth adding an option to enable/disable it when the issue can easily be fixed.

#16 Updated by skidau over 8 years ago

  • Status changed from Questionable to Won't fix

Submit a patch.

Also available in: Atom PDF