Project

General

Profile

Emulator Issues #2998

Super Monkey Ball 2 Broken Sound

Added by vgvideogalaxy almost 11 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
DSP
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Play Super Monkey Ball 2
2. In the Main Menu and the Stages, there is no background music

What is the expected output? What do you see instead?
- The Game should be playing the background music when playing the levels

Dolphin version with the problem? Other Dolphin version without the
problem?
- All of them have the problem

32-bit or 64-bit and any other build parameters?
- 64-bit

OS version and versions of tools/libraries used?
- Windows 7

Please provide any additional information below.


Related issues

Is duplicate of Emulator - Emulator Issues #4452: DSP HLE has various instances of producing the wrong and/or no outputInvalid

History

#1 Updated by DimitriPilot3 almost 11 years ago

The problem, apparently, is that some of the game's music is cut off starting from the "PRESS START/PAUSE" screen. It works fine (somewhat) in R4710 but not in R4788, so the breaking revision must lie between these 2 revisions...

#2 Updated by DimitriPilot3 almost 11 years ago

After lots of tests and "soft resets", I found that in R4710 there are only audio-affecting problems 1~2% of the time (in other words, rarely), whereas in revisions R4711 and newer the audio fails more often...

Actually, it's not a music cutoff (because the music may stop at the "PRESS START/PAUSE" screen but play again in the menus). I'm talking about random glitches that cause, for example, the music and/or sound effects not to play (or to play with a low volume). The game seems to hang/crash too, sometimes...

#3 Updated by skidau over 10 years ago

  • Category set to dsp

#4 Updated by Anonymous about 10 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF