Project

General

Profile

Emulator Issues #3011

Paper Mario 2 Horde Mechanic Issues

Added by DeckmasterSean over 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Play Paper Mario 2/Paper Mario: Thousand Year Door
2. Go to any event where a horde of sprites will appear (X-naut horde at the game's beginning, Dry Bones horde in Chapter 1, Punie horde in Chapter 2 THIS ONE IS MOST IMPORTANT)

What is the expected output? What do you see instead?
For the sprites to appear on screen and not disappear. However, any sprites involved in the horde mechanic do not appear, and only leave behind a shadow.

Dolphin version with the problem? Other Dolphin version without the
problem?
This problem seems to be evident in all builds, if there are builds that don't have the error, I'm not aware of them.

32-bit or 64-bit and any other build parameters?
Played on r5998, r6002, and r3207, all x64.

OS version and versions of tools/libraries used?
Windows 7

Please provide any additional information below.

Certain circumstances can cause the horde or parts of it to disappear. This not only drops the framerate considerably (I could get 50-60 FPS even with the punie horde following me, but once they disappeared, it would drop to as low as 8-9 FPS.), but it also renders Chapter 2 borderline unplayable, with mechanics that require you to have a horde with you and trigger the conditions that will make them vanish, requiring precise timing and possible savestate abuse to prevent.

On another note, fixing this may also fix other reported issues involving a stuck at the red door in Chapter 2, as that seems to be related to a plot relevant NPC vanishing as the cutscene triggers.

Them not appearing is graphically oriented, their disappearance may be connected or may just be a fatal issue with the emulator.


Related issues

Is duplicate of Emulator - Emulator Issues #360: Bounding Box registers are not working correctlyFixed

History

#1 Updated by PianoGamer over 9 years ago

Rodolfo said copy EFB is missing rendering to multiple textures, used for NSMBWii coins, could it also be used for this?

#2 Updated by AHeinerm over 9 years ago

This is a duplicate: issue 360

#3 Updated by NeoBrainX about 9 years ago

  • Status changed from New to Duplicate

#4 Updated by shayla.mihalcin almost 8 years ago

Same Issue, Win 7 X86 Dolphin 3.0.

Also available in: Atom PDF