Project

General

Profile

Emulator Issues #3013

Big brain academy all black

Added by giaga7 almost 10 years ago.

Status:
Invalid
Priority:
Normal
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

The wii game Big brain academy is all black, I tried it with dx9, 11, opengl, with enable efb to ram and to texture, with xfb and real xfb, with jit and jitil but nothing it's always black, only with enable acces cpu-efb I see some lines... First two screen are from dolphin, others are from the real game!

History

#1 Updated by marcel.werner3 almost 10 years ago

I can only say it's been like this since like forever...I don't think it has ever been showing right.

#2 Updated by giaga7 almost 10 years ago

Yes I know it, but I didn't find anything about this issue!! But I hope it will be fixed soon!:)

#3 Updated by marcel.werner3 almost 10 years ago

yeah, it's good you made this issue...just wanted to say it's not something that got broken recently or anything.

#4 Updated by marcel.werner3 almost 10 years ago

Owner: rodolfoosvaldobogado

#5 Updated by marcel.werner3 almost 10 years ago

damn, doesn't work xD

#6 Updated by luisr142004 almost 10 years ago

lol, doesn't work that way xD

#7 Updated by marcel.werner3 almost 10 years ago

thx -_- maybe CC NeoBrain, too...I think he's also into fixing gfx stuff.

#9 Updated by giaga7 almost 10 years ago

I'm happy!!.^ I've contributed to the development and improvement of this fantastic emulator!!;) I hope it will be fixed soon!:) You guys have made a very very good work, I love this emulator and I will support you and will try to help as much as I can!:)

#10 Updated by samljer almost 10 years ago

I dont know about you guys, but this game was flawless for me using OpenGL plugin
SVN R 6092 "Custom btw, so 6092A" but the changed i made wouldnt have effected it.

DirectX9 "All black"
DirectX11 "All Black"
OpenGL "Worked Perfectly!"

SPECTS:
AMD PhenomII X4 920 2.8GHz AM2+
M2N-E
3GB DDR2 667MHz
ATi Radeon Saphire 5770 DDR5 PCIX16 "Single Card"
Windows 7 Ultimate "All updates installed 8/13/2K10" 64bit host OS

Running in 720P

[Colors are of course messed up, as thats just common with OpenGL plugin for
as long as i can remember, but its a fully playable game, 4 stars from me!]
Some 2D pics wernt visible, but i fixed that with some OpenGL settings
but just cant remember what I did :P Namely just the Mii images
when I was enrolling, havent noticed missing stuff since, but then again i fixed it so.

SCREENIES BELOW!!!!

I notice in the emulater the chalkboard seems to be moving a bit
it may be 2D graphics over a video of some sort, causing the bad emulation?
dunno, thats for the devs, i dev otherstuff and lost in EMU :P

#11 Updated by samljer almost 10 years ago

"JUST FIGURED IT OUT!!!!"

Disable EFB copy "Ram or Texture, doesnt matter, TURN THAT RIGHT OFF"
and it worked, even in DirectX9 and 10

I have it flawlessly working in DX9 with that option OFF

#12 Updated by giaga7 almost 10 years ago

I will try it as soon as possible! And sorry, I remembered that I tried in opengl too, maybe I forgot to change settings! I will try!

#13 Updated by giaga7 almost 10 years ago

Yes it works, and also pretty good, only something doesn't show correctly! I didn't try disabling EFB copy because I thought it never can work with that options off, instead it wowkr and better too!

#14 Updated by giaga7 almost 10 years ago

For me opengl dx 9 and 1 with erfb copy activated doesn't work, disabling efb copy all work enough fine!

#15 Updated by glennricster almost 10 years ago

I have found that commenting out line 344, and uncommenting lines 345-349 of Source/Core/VideoCommon/Src/VertexShaderGen.cpp improves texture rendering for Big Brain Academy. This was put in somewhere around revision 4000, and reverted in revision 4876. This is with the OpenGL plugin.

#16 Updated by giaga7 almost 10 years ago

So,what does it change making this?:)

#18 Updated by skidau over 9 years ago

  • Status changed from New to Invalid

Solved by disabling EFB copy.

Also available in: Atom PDF