Project

General

Profile

Actions

Emulator Issues #3059

closed

Batman: Dark Tomorrow - Slow in-game speed

Added by ryan.hoss over 13 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?

  1. Simply playing the game in Dolphin (in-game) 2.

What is the expected output? What do you see instead?

In most places, the game runs at about 60-75% speed. I can't seem to really get it above that. This is only-in game--the menus and such are just fine.

Dolphin version with the problem? Other Dolphin version without the
problem?

I've tried this on both versions 4798 and 6092.

32-bit or 64-bit and any other build parameters?

Both 64-bit. I've tried this game on both:

a Desktop PC with a GeForce 9800 GT, and
an Alienware M17x with dual GeForce 260M GTX cards

OS version and versions of tools/libraries used?

Windows 7 64-bit

Please provide any additional information below.

MMU needs to be enabled in order to play this game. Also, the cutscenes won't work because they are .h4m files--you have to either wait until they're over or skip over them (some of which you can't).

Actions #1

Updated by Billiard26 over 13 years ago

Perhaps your CPU is too slow,
but how would we know, you didn't post your CPU info. :/

Actions #2

Updated by ryan.hoss over 13 years ago

Ah, sorry about that. Here's what I'm currently using:

Alienware M17x R1

CPU: Intel(R) Core(TM)2 Extreme CPU Q9300 @ 2.53GHz
RAM: 4 GB DDR3-1066 RAM
GPU: GeForce 260M GTX x 2 in SLi mode
HDD: 2x300GB in RAID
OS: Windows 7 64-bit

That would totally suck if a quad-core processor couldn't run a game from 2003 properly.

Actions #3

Updated by Billiard26 over 13 years ago

"That would totally suck if a quad-core processor couldn't run a game from 2003 properly."

Remember, you are Emulating a game from 2003.
Also, Dolphin can not fully take advantage of 4 cores.
Currently, and maybe indefinitely, Dolphin will significantly benefit from only 2 cores.

Actions #4

Updated by GCNWIIUploader over 13 years ago

your cpu's clock speed is too slow, try overclocking it

Actions #5

Updated by ryan.hoss over 13 years ago

Ah, right. I'll definitely try it. Don't want to be too harsh on it, but do you have any clock speed suggestions?

Actions #6

Updated by skidau over 13 years ago

  • Status changed from New to Invalid

This game is slow because the MMU emulation. That is expected.

Actions

Also available in: Atom PDF