Project

General

Profile

Emulator Issues #3075

Load a game for the second time improve fps, about +8 +9 frames!!

Added by giaga7 almost 10 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Hi! Today I was playing SMG 1 and noticed that a first time I launched it my fps after loading were about 49-50, than I stopped it , and without modifying anything I re-clicked on the game and after loading my fps were 57-58!!O.o How is this thing possible?? I'm using last 6109 on windows 7 x64, I'm using dx9, JIT and vsync off, with frame limiter set to 60 and "limit by fps" Unchecked, off! Maybe modifying something is possible to make the game run everytime at 57-58 fps!! Id needed I will post images or a video!

History

#1 Updated by giaga7 almost 10 years ago

Tried also with vsync and limit by fps checked!

#2 Updated by frango0010 almost 10 years ago

In what scene did you get this FPS?

#3 Updated by giaga7 almost 10 years ago

I wrote it, after loading of a savegame of Super mario galaxy 1, when you start, I load the game and wait, don't move anything, the first time I make 48 fps, the second max 58 but usually 57!! And I don't know why this happens!!

#4 Updated by frango0010 almost 10 years ago

I'll download r6109 and see what happens, as with r6104 i see no difference...

#5 Updated by frango0010 almost 10 years ago

No difference... First savegame load: 34FPS, second load: 34FPS... The same as build r6104...
I'm using Jit, OpenCL On, Limit by FPS ON, CPU -> EFB on (as it's required to play SMG), I'm also using r6109 on windows 7 x64, DX9, vsync off, EFB Scale x1...

#6 Updated by frango0010 almost 10 years ago

Questionable... Post a video plz...

#7 Updated by giaga7 almost 10 years ago

I not use opencl because it lock my fps and slowdown for me... I've a 5870, me too windows 7 x64, efb 2x, jit, vsync on! I will post a video or simply two or three images!

#8 Updated by ivicamarkovic1975 almost 10 years ago

If i am correct, it has something to do with shader cache. And it happens when you start your game for the first time ( or test new revision of Dolphin ). First time you experience lower fps, and after that it jumps. And it is known behavior. If you are experience it every time you start the same revision of Dolphin, than your shader cache is not saved (but i can not image situation other that on purpose).

#9 Updated by frango0010 almost 10 years ago

I tried lots of different configs but I couldn't reproduce this...

#10 Updated by ivicamarkovic1975 almost 10 years ago

You need to run the game for the first time on emulator. During this, it will write shader cache for that particulare game. Only in that time you will experience small fps drop. After that, every other time, your fps will be as usual. I noticed that in FF:CB (probably in SMS and ZTP, but not sure) and this is hardly an issue, not even worth of mention. So, this issue should be closed.

#11 Updated by IcemanSRB almost 10 years ago

ofc its cache it help with loading textures because its stored in it.once u load game it put them in there.therefore u get speedup

#12 Updated by giaga7 almost 10 years ago

Ok ,fro now I can't make a video but I've re tested and for now they stay at 50 and don't go over!! I don't know why I've got 58 frames that time, as soon as I can, I will try another time and make a video!! Anyway thanks for explanation guys!:)

#13 Updated by luisr142004 almost 10 years ago

this issue is most prolly cuz of the caches dolphin saves ;)

#14 Updated by NeoBrainX over 9 years ago

  • Status changed from New to Invalid

yeah, whatever. We don't have any magic "run faster on second try" code in Dolphin...

#15 Updated by giaga7 over 9 years ago

Yes I know!!:P It would be awesome! Anyway I still have about +6 +7 frames on the second time I boot the games, maybe the shader cache!!

Also available in: Atom PDF