Project

General

Profile

Emulator Issues #3087

Background Follows Player in Ty the Tasmanian Tiger

Added by jayork42 about 10 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Start Ty the Tasmanian Tiger
2. Start a new game or load a game

What is the expected output? What do you see instead?

The background should remain static and in the right position. Instead it moves relative to Ty, making it difficult to see the rest of the environment. This happens in Rainbow Cliffs as well as other levels.

Dolphin version with the problem? Other Dolphin version without the
problem? r6106

32-bit or 64-bit and any other build parameters?
x86

OS version and versions of tools/libraries used?
WinXP Pro MCE

Please provide any additional information below.
Screenshots below. Notice the rocks in the background intercept the trees.
http://i33.tinypic.com/ic451g.png
http://i35.tinypic.com/1672nth.png

History

#1 Updated by samljer about 10 years ago

Is this with OpenGL or DirectX?

Im curious because I have that issue in lots of games using OPENGL, and have
never actually seen it using directx.

#2 Updated by jayork42 about 10 years ago

It happens with both. Could this be a problem with video common?

#3 Updated by skidau almost 10 years ago

  • Category set to gfx

#4 Updated by jayork42 over 9 years ago

This works in software by the way.

#5 Updated by nash679 almost 9 years ago

this is fixed

#6 Updated by jayork42 almost 9 years ago

Awesome! Been looking forward to playing this game.

#7 Updated by skidau almost 9 years ago

  • Status changed from New to Fixed

#8 Updated by jayork42 almost 9 years ago

Using Dolphin 3.0-159, this is fixed. However, someone broke this again in the latest revision. I may take some time to narrow down at which point it was broken later.

#9 Updated by hatarumoroboshi almost 9 years ago

It should be due to Revision 8f31968466fb (r3.0-192)

#10 Updated by triforcechosen26 over 5 years ago

What was done to fix this? I am still having this problem

Also available in: Atom PDF