Project

General

Profile

Emulator Issues #3101

Wiimotion plus problem

Added by jvabbdac almost 10 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Use real wiimote with motionplus
2. Starts a game like Wii Sports Resort

What is the expected output? What do you see instead?

Showing a screen "WiiMotion plus disconnected, please, reconect", Remove and put again motionplus, in about couple seconds the message shows again.

Dolphin version with the problem? Other Dolphin version without the
problem?

Lastest, in 6100 its fine
32-bit or 64-bit and any other build parameters?

X64
OS version and versions of tools/libraries used?
Win7 64
Please provide any additional information below.


Related issues

Has duplicate Emulator - Emulator Issues #3678: No wii Motion Plus Connected error in Red Steel 2 with dual core activatedDuplicate

History

#1 Updated by Billiard26 almost 10 years ago

If it works in r6100, figure out which revision broke it.
I don't see any changes after r6100 that would cause it not to work.

#2 Updated by Billiard26 almost 10 years ago

Also, which plugins have the issue?

#3 Updated by jvabbdac almost 10 years ago

I tried with both... Try it, use real wiimote with motion plus.

#4 Updated by Billiard26 almost 10 years ago

I have no motion plus games, you didn't answer all of my questions ;).

#5 Updated by jvabbdac almost 10 years ago

Sorry :) I try a couple builds later than 6122, and I only get work with 6089 (sorry, litle mistake... I try 6100 and same problem). If you have wiimotion plus you have the game sport resort, right? Come in a bundle! Try get a wiiremote with motion plus... This emulator rocks... I can use 6089. no problem at all, but I want just give a litle help to the comunit.

#6 Updated by NeoBrainX almost 10 years ago

WMPs are available without the bundle as well, you know ;)
Anyway as he said, try to narrow down the issue to the exact revision which broke stuff, please. There are archived builds on www.dolphin-emulator.com.

#7 Updated by marcel.werner3 almost 10 years ago

I never had that issue...if there is any, it's new...but I somehow doubt it...

#8 Updated by jvabbdac almost 10 years ago

I try out lastest build and I sill with the problem here... Sport Resort desconnetc wiimotion... Strange, if I choose emulated controller, and check "motion plus" the problem still. Can be my game?

#9 Updated by manco81 almost 10 years ago

I can confirm this problem also to r6170.

#10 Updated by manco81 almost 10 years ago

Disabling Dual Core option I have any problem. The problem is the use of Dual Core!!!

#11 Updated by naakolive almost 10 years ago

it's not because of dual core. Its a bug in dolphin. You can correct it by going to the wiimote setting while the game is in action and the uncheck the motion plus part then ok. then again go to the wiimote settings and check the motion plus settings and press ok. do this until the recalibration screen appears.

#12 Updated by daws72 almost 10 years ago

I can't understad what you mean... I use real wiimote + wimotion plus.

#13 Updated by manco81 almost 10 years ago

With a real wiimote and dual core option on, I haven't problems; with option on I have the problem. Always with Wii Sport Resort. r6120.

#14 Updated by naakolive almost 10 years ago

while u are runing the game in the main window of dolphin. if u get the message from the game that the motion plus is disconnected do the following while the game is running with the wii motion plus disconnected message.
the instructions i gave before.

#15 Updated by Anonymous over 9 years ago

issue 3678 has been merged into this issue.

#16 Updated by danielfrancosantana over 9 years ago

I have this problem only with Red Steel 2 (and ONLY with DUAL CORE activated), not with Wii Sports Resort or Grand Slam Tennis.

#17 Updated by hatarumoroboshi over 9 years ago

Maybe this problem in Wii Sports Resort was caused by the old plugin, with the new one from my testing (until now) I have experienced that only Red Steel 2 has some disconnection problems in the game-menu, but you can always reconnect the Wiimote using ALT+F5...

#18 Updated by skidau over 9 years ago

  • Status changed from New to Fixed

Also available in: Atom PDF