Project

General

Profile

Emulator Issues #3155

Smg 1 & 2 graphic problems since r6149 [DL cache enabled]

Added by giaga7 about 10 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Hi, playing Super MArio galaxy 1 & 2 I noticed some problems, some effect are "squared", and when I look in first person the game become totally broken, I made some screenshot:
First and second are example of squared and broken effect, like star shining or in the title or purple luma shining...

http://img295.imageshack.us/img295/663/sb4p012.png
http://img715.imageshack.us/img715/7913/sb4p016.png

In these other three I was wathing in first person to the purple Luma and suddenly all start to be broken and also after returned to third person it still looks so bad...

http://img59.imageshack.us/img59/3518/sb4p013.png
http://img822.imageshack.us/img822/7108/sb4p014.png
http://img444.imageshack.us/img444/2015/sb4p015.png


Related issues

Has duplicate Emulator - Emulator Issues #3156: Smg 1 & 2 problems in last revisions Duplicate

Has duplicate Emulator - Emulator Issues #3225: Resident evil Darkside chronicles HungsDuplicate

Has duplicate Emulator - Emulator Issues #3227: Dlist cache causing Resident Evil GC to CrashDuplicate

Has duplicate Emulator - Emulator Issues #3303: DList caching breaks Wii SportsDuplicate

Has duplicate Emulator - Emulator Issues #3311: Vertex Loader Crash by playing "New Super Mario Bross"Duplicate

History

#1 Updated by giaga7 about 10 years ago

In last commits I noticed a lot of graphical problems, like in wii sport, black texture or black screen or a lot of missing textures and effects!

#2 Updated by marcel.werner3 about 10 years ago

don't just say "last or latest revisions", say exactly what revision you were having those issues with.

#3 Updated by giaga7 about 10 years ago

Oh yes sorry, I strangely forgotten to write it!!:S It's 6154, and i noticed that wii sport looks good in r6148, with windows 7 x64

#4 Updated by marcel.werner3 about 10 years ago

then you should try the most recent rev cuz something was fixed since then.

#5 Updated by giaga7 about 10 years ago

Oh yes, yesterday the new one was the r6156, I will try and Tell you! Thanks!:)

#6 Updated by frango0010 about 10 years ago

The squary effects is because DlistCaching is TRUE in your graphics plugin ini file, in User>Config... This speeds up the emulation, but bugs LOTS of games... Luckily the only thing wrong with SMG is some squary effects... nothing critical... But you can always turn it OFF by setting "DlistCachingEnable = FALSE" on the ini, with the cost of some FPS...

#7 Updated by giaga7 about 10 years ago

Thanks for this!:) I hope dlist cache will be fixed soon!! But now it works perfectly!!

#8 Updated by NeoBrainX about 10 years ago

issue 3156 has been merged into this issue.

#9 Updated by NeoBrainX about 10 years ago

  • Issue type set to Bug
  • Category set to gfx

#10 Updated by BhaaL about 10 years ago

Can you try if r6169 improved anything?

#11 Updated by d4rro87 about 10 years ago

squaring effects still present in latest revisions (r6172), but the boost of fps is DEFINITELY worth leaving Dlistcaching = True in my opinion, in SMG2 anyways, as the squary effects aren't that bad..
still..it'd b ideal if the glitches can be fixed while keeping the performance boost..lol..but it's still playable as is..

#12 Updated by giaga7 about 10 years ago

I tested with r6170, with dlist caching enabled, suqred effect are still present, not only, Super mario strikers charged footbal doesn't work, wii sport show black textures, and some other games doesn't work or show graphic problems!! Disabling it all return normal... But enabling it I've a very very good fps boost, smg 1 & 2 never under 50 fps!!:D

#13 Updated by giaga7 about 10 years ago

Still present all the problems for me i r6216, and I noticed a VERY HUGE SLOWDOWN from 6149 to r6216 (DL cache enabled), before I had 57-58 fps, now 46, and disabling it I've about 45, before I had 49-50, I don't know why, I read everywhere speedup, but every rev it's slowdown!:( All fps are taken from SMG 1 after loading in observatory!

#14 Updated by frango0010 about 10 years ago

That's because many bugs in the DL Cache has been corrected on r6205... Try enabling Block Merging in the Game Properties... On SMG1 (and maybe 2) it will give you almost the same boost as pre-r6205 dlist cache revs, with no additional graphical glitches...

#15 Updated by Billiard26 almost 10 years ago

issue 3225 has been merged into this issue.

#16 Updated by Billiard26 almost 10 years ago

issue 3227 has been merged into this issue.

#17 Updated by Billiard26 almost 10 years ago

issue 3303 has been merged into this issue.

#18 Updated by Billiard26 almost 10 years ago

issue 3311 has been merged into this issue.

#19 Updated by wespipes69 almost 10 years ago

Maybe we should label this option "experimental" or have a tool tip warning about stability problems.

#20 Updated by NeoBrainX almost 10 years ago

Has this been fixed meanwhile?

#21 Updated by giaga7 almost 10 years ago

I tested r4515 and still it was not fixed with dlcache!! I will test last revs!:)

#22 Updated by marcel.werner3 almost 10 years ago

Issues are still there. I've also found quite a few other games which have glitches with DList Cache enabled (RE Umbrella Chronicles has white textures, in NSMB when Mario lifts his hat at the end of a level, there go some crazy glitches, DKCR seems to only have some glitchy textures on the save game screen, etc)

#23 Updated by skidau over 9 years ago

  • Status changed from New to Fixed

The glitches have been fixed in the latest release (r7150).

Also available in: Atom PDF