Project

General

Profile

Emulator Issues #3162

GCN IPL: RTC thinks it's 2018

Added by MofoMan2000 about 10 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. In settings, uncheck "skip gamecube BIOS" or some such.
2. Look at the RTC in the BIOS.

What is the expected output? What do you see instead?
Well i'd HOPE the time and date would be accurate. Instead it's about 8 years 2 months in the future.

Dolphin version with the problem? Other Dolphin version without the
problem?
R6158 and onwards have the problem. I don't think it has ever been accurate, really.

32-bit or 64-bit and any other build parameters?
As far as I know, all builds.

OS version and versions of tools/libraries used?
WinXP x86, VC2008, USA IPL

Please provide any additional information below.
Someone should be able to figure this one out, especially with all the recent work on the RTC.

History

#2 Updated by BhaaL about 10 years ago

Comment by dok.slade, Yesterday (29 hours ago)

GCN IPL is seen as a Wii ISO in the boot manager and therefore it uses Wii RTC.
I managed to get it working if I force GC RTC in EXI_DeviceIPL.cpp (disabling lines 274-276), but then GC homebrews won't be accurate anymore.

I'd say the real question is why the GC IPL is seen as Wii ISO.

#3 Updated by Anonymous about 10 years ago

erm, how are you booting the ipl such that it is seen as a wii iso? the only real way (currently) to load the ipl is to load a gc game.

#4 Updated by dok.slade about 10 years ago

Maybe I'm not doing the right way, but the only way I found to start the IPL without any disc loaded (so that I can go to the GC menu) is to load the IPL as a DOL file.
The problem is that DOL is mapped at 0x8130000, which is seen as a Wii loading address in CDolLoader::IsDolWii().

#5 Updated by MofoMan2000 about 10 years ago

You can get to the GC menu with a disk loaded, just hold the A button while you see the little cube rolling around.

#6 Updated by skidau almost 10 years ago

  • Status changed from New to Invalid

I have tested r6224 with Mario Party 6 GC USA and the USA IPL. The time and date were correctly shown in the Calendar menu.

#7 Updated by Anonymous almost 10 years ago

I have not tried, but the PAL codepath will generate a different SRAM file. Perhaps there is an issue with the RTC bias stored there.

#8 Updated by MofoMan2000 almost 10 years ago

Whoops, meant to comment on this a long time ago.

Not sure why this was marked invalid but it's still an issue. Though technically now the RTC thinks it's 2019.
http://www.mediafire.com/imageview.php?quickkey=uxoji28qer94ihb&thumb=5

Loaded with the USA IPL and Super Smash Bros. Melee NTSC.

To make matters worse, while I was watching it the clock was running at 2x speed, matching two seconds for every real second. But that's probably another issue altogether.

Also available in: Atom PDF