Project

General

Profile

Emulator Issues #3169

Sometimes after loading save state (in SMG2), controller bugs out (either completely goes dead, or works for a few seconds then sticks on last keypress) until emulation is restarted.

Added by d4rro87 almost 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1.Run Game (definitely happens all the time with Super Mario Galaxy 2; havn't been playing much else to encounter the problem)
2.Load savestate

What is the expected output?
Controls work fine

What do you see instead?
Controls bug out

Dolphin version with the problem? Other Dolphin version without the
problem? Mpt sure, as there have been alot of updates recently, but i didnt notice it in the early r6150's, definitely present in r6167

32-bit or 64-bit and any other build parameters?
Win7 x64

OS version and versions of tools/libraries used?

Please provide any additional information below.
Sometimes when multiple savestates are used, the issue may be present for a particular save state, but not for another, even during the same emulation cycle.


Related issues

Is duplicate of Emulator - Emulator Issues #2484: Savestates do not workFixed

Has duplicate Emulator - Emulator Issues #3174: Controls gone crazy after load stateDuplicate

History

#1 Updated by RamboRentner almost 10 years ago

I can confirm this in New Super Mario Bros on the 32 Bit Dolphin r6166 with windows 7 home premium.

#2 Updated by d4rro87 almost 10 years ago

still present in r6169

#3 Updated by otomospirits almost 10 years ago

Have you guys tried enabling "Reconnect Wiimote on disconnect" on the wiimote plugin control panel?

#4 Updated by d4rro87 almost 10 years ago

yup, always on for me..

#5 Updated by marcel.werner3 almost 10 years ago

for me it always helps to unplug the nunchuk and plug it back in...dunno if it works the same with an emulated one shrug

#6 Updated by d4rro87 almost 10 years ago

just checked (r6170), it doesn't even acknowledge that the nunchuk has been removed.

#7 Updated by Billiard26 almost 10 years ago

The wiimote state is not properly saved/loaded.
The reason removing the nunchuk beforehand helps is because without an extension, there is no encryption going on, and no encryption key which could differ between different times in the game.

#8 Updated by Billiard26 almost 10 years ago

issue 3174 has been merged into this issue.

#9 Updated by jodr666 almost 10 years ago

So this might be a plugin problem not with the emulator itself?

#10 Updated by d4rro87 almost 10 years ago

hmm, i thought so myself. but i recently got the problem occurring while playing smash brawl, using my xbox controller mapped to the gc controller plugin..as opposed to using my kb mapped to the wii plugin like i play smg2..so it dosnt seem to be a particular controller plugin..considering this only started happening in the r616x revisions..some small edit may have broken things..

#11 Updated by jizardy almost 10 years ago

i can confirm this on Tales of symphonia Dawn of the new world & Mario Galaxy 2. it happen someties and someties is allright.

#12 Updated by d4rro87 almost 10 years ago

still rampant in latest revisions (r6197)..sigh..basically makes savestates unusable..
i wonder what caused it to break :S

#13 Updated by Anonymous almost 10 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF