Project

General

Profile

Emulator Issues #3176

[GUI] "Skip GC BIOS" setting is forgotten

Added by MofoMan2000 about 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. In settings, uncheck "Skip GC BIOS"
2. Boot any Wii game (MUST be a Wii game)
3. Go back into settings (with or without stopping the Wii game)

What is the expected output? What do you see instead?
I expect the option to stay cleared. Instead, it is checked again.

Dolphin version with the problem? Other Dolphin version without the
problem?
I don't know if it has ever not had this problem, but I'm currently using r6174 and this problem has been around for a while, at least 100 revisions (I never cared much before then).

32-bit or 64-bit and any other build parameters?
If it matters, x86.

OS version and versions of tools/libraries used?
Again, I doubt it matters but
WinXP x86
VC2008
USA IPL (NTSC)
JIT recompiler core

Please provide any additional information below.
Seems like a simple GUI bug, ought to be easy enough to fix.


Related issues

Is duplicate of Emulator - Emulator Issues #3004: Game properties and settings missingFixed

History

#1 Updated by BhaaL about 10 years ago

  • Status changed from New to Accepted

Noticed this too, but it might be a similar case to the game properties/dual core problem (overriding with game settings also saves real settings)

#2 Updated by skidau about 10 years ago

Yeh, it's a pretty simple fix:

When Dolphin loads, copy the "ini config" to a "working config". Dolphin should reference the "working config" at runtime. If settings are changed via the config dialog, save them to the "ini config". If dolphin needs to change any parameters at runtime, change the "working config". Essentially we need to make a copy of the config for runtime use. At the moment we modify the "ini config", which gets saved on exit and produces this bug.

I'm not volunteering to fix it :P

#3 Updated by frango0010 almost 10 years ago

That happens because, everytime you boot a game that can't use the bios somehow (no bios file available, or wii games, which doesn't use gc ipl bios), the option is checked again.

#4 Updated by skidau almost 10 years ago

  • Status changed from Accepted to Duplicate

#5 Updated by MofoMan2000 almost 7 years ago

issue 3004 has been completely deleted, but this is still an issue. Seriously, the only time it should automatically check itself is if the IPL doesn't exist. There's no reason to force it enabled if a Wii ROM is booted.

Also available in: Atom PDF