Project

General

Profile

Emulator Issues #3198

Castlevania Rebirth not working with "copy to RAM" selected.

Added by otomospirits almost 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1.Select copy to RAM in any gfx plugin.
2.Load Castlevania Rebirth and reach to the point where you select "start game", black screen after that.

What is the expected output? What do you see instead?
Same as with "copy to texture" selected, games starts normally.

Dolphin version with the problem? Other Dolphin version without the
problem?
6181 and 6197, last working version is 6110

32-bit or 64-bit and any other build parameters?
32-bit

OS version and versions of tools/libraries used?

WinXP SP3

Please provide any additional information below.

If bug can't be confirmed locally videos will be provided.


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by otomospirits almost 10 years ago

My mistake, is not even working in 6110. As a reference, other games like Crystal Defenders and the newer Blaster Master Overdrive are working with copy to RAM selected.

#2 Updated by skidau almost 10 years ago

  • Status changed from New to Duplicate

#3 Updated by miltos07 over 9 years ago

I can confirm that copy to RAM causes the blank screen issue in r7434.
DX9 and OpenGL renderers work fine with copy to texture, DX11 causes graphics glitches even before starting the game and sometimes totally scrambled output. It seems that this issue needs reopening. I hope this info helps. You can see attached screenshot.

#4 Updated by skidau over 9 years ago

  • Status changed from Duplicate to New

#5 Updated by Billiard26 over 7 years ago

  • Issue type set to Bug
  • Category set to gfx

#6 Updated by tommyhl2.SS over 7 years ago

  • Status changed from New to Accepted

I can confirm this as well. EFB to Ram after the "start game" button is pushed, the screen is black and goes to 0fps. EFB to Texture works normally.

#7 Updated by JMC4789 about 6 years ago

I can confirm this is still happening in 4.0-1533

#8 Updated by JMC4789 about 6 years ago

  • Category deleted (gfx)

This is a GPU synchronization issue much like F-Zero GX and many other games.

Using single core + EFB2Ram works fine.

Not sure this should be accepted or merged into something else?

#9 Updated by JMC4789 about 6 years ago

  • Status changed from Accepted to Duplicate

Going to make a judgment call and merge this with the "dualcore is unstable" master issue. Anyone else with issue rights can override me if you disagree.

Also available in: Atom PDF