Emulator Issues #3240

F-Zero GX NTSC Custom Machine Error

Added by Eivindjorgen almost 7 years ago.

Status:Fixed% Done:

0%

Priority:Normal
Assignee:-
Category:-
Target version:-
Operating system:N/A Relates to performance:No
Issue type:Bug Easy:No
Milestone: Relates to maintainability:No
Regression:No Regression start:
Relates to usability:No Fixed in:

Description

In the American version of F-Zero GX is two of the body parts not showing, the cockpit and the boost part.

I don't think the OS or Dolphin version have an affect on the issue.
Can't see the body parts that's all.


Related issues

Duplicated by Emulator - Emulator Issues #3949: F-Zero GX, corrupted memory card? custom vehicle not showing right? Duplicate

History

#1 Updated by multi-ultra2 almost 7 years ago

To give more details, when changing machine parts, you can see everything. But on the custom machine selection (see attached pic), you can only see the body part of the machine. Same applies when using the machine for the race. The driver will float in mid-air above the body part and also there won't be any lights at the back of the machine, while driving.

#2 Updated by Eivindjorgen almost 7 years ago

Ehem, well I suck in english so i thank you for explaining it better than me!

#3 Updated by wespipes69 almost 7 years ago

Confirmed here as well. I take it no one has found a way to make these appear properly? Have we tried all setting changes and plugins?

You need to make these custom racers to get far in the game, but your vehicle looks ridiculous only partially rendered, with the pilot floating in the air! :) Just look!

#4 Updated by Eivindjorgen almost 7 years ago

o yeah:P! i hope someone will fix it, but maybe it will take some time...
maybe every settings should be tried out before fixing the issue?

#5 Updated by wespipes69 almost 7 years ago

Ok, I've tried every possible config I could think of and nothing shows the other 2/3's of the car. So this just definetely needs a fix.

#6 Updated by wespipes69 over 6 years ago

Still no change for this on r6641 - parts of the vehicle are just alpha for some reason.

#7 Updated by skidau over 6 years ago

issue 3949 has been merged into this issue.

#8 Updated by theraptor01 over 6 years ago

the framerate increased dramatically with the newest versions (with very few hiccups sometimes), though this particular problem is still there.

#9 Updated by godisgovernment over 6 years ago

  • Status changed from New to Fixed

Works fine here. tested on r7497

#10 Updated by wespipes69 over 6 years ago

Godisgovernment, please reopen as this issue still exists. That is unless you have some magical config that makes this work. Otherwise, I've tried every setting/combo (including fresh install of r7497 with pure defaults) possible and only the "body" part is displayed, not the "cockpit" or "booster". You can see this by simply going to the garage with the following save:
http://www.megaupload.com/?d=9WE5HZBD

#11 Updated by wespipes69 over 6 years ago

nudge, nudge...

#12 Updated by wespipes69 over 6 years ago

It is not fixed. Can we please reopen this - and then delete my last comments here? Thanks!

#13 Updated by godisgovernment over 6 years ago

It worked fine here. I'll check out your save later.

#14 Updated by godisgovernment over 6 years ago

It is rendered correctly.

#15 Updated by wespipes69 over 6 years ago

Weird! Again, I've tried defaults and i don't get that. I'm not sure if others are seeing this properly yet either.

Can you zip up your Config directory so I can track down the difference? I image it's probably not hardware difference(hopefully not).

Here's my screens again on the latest rev. 1 showing the full vehicle (disregard the transparant parts there) and the 2nd showing of what I see in races - just the "body" part.
http://imageshack.us/photo/my-images/543/gfze011.png/
http://imageshack.us/photo/my-images/707/gfze012.png/

Also, another related thing here that further proves an issue here (at least with some config) - when I go to "Apply Emblem" in Customize, the game will reboot if I try to place an emblem on either the cockpit or booster. It seems like it's trying to render the parts on a new screen but then just craps out. I can place a emblem just fine on the body.

Something is causing these other parts to not render properly and lead to crashes. I want to get to the bottom of this. Hopefully, we can figure out whats going on here!

#16 Updated by godisgovernment over 6 years ago

have you tried single core mode? Dual core works fine here, but I'm pretty sure the reboot stuff is caused by desyncs in dual core mode.

#17 Updated by wespipes69 over 6 years ago

Nope, it hard locks on SC mode. Your not seeing it cause for some reason, you have no problem rendering all the parts. Since in my config, they cannot be rendered and I try entering a scene that must render them and allow me to move around the part, must be causing an exception and failing out.

Can you send me you config folder - it should be like 10k after zipped. That should hopefully be enough to track this down.

#18 Updated by wespipes69 over 6 years ago

Here's my current config if you want to see also!

#20 Updated by wespipes69 over 6 years ago

Thanks! I ditched mine, copied yours over and booted the game - other parts are still not displayed and trying to apply an emblem to them causes a lock-up.

I spent another hour toggling every setting possible and no change. Tried uncompressing the iso, which by the way is NTSC.

It must be a difference in hardware. I'm using Nvidia 460gt with the lastest official drivers. I'm using vanilla vid card settings as well. I hope you use a ATI card, since we'll then have our answer I think here! :)

#21 Updated by godisgovernment over 6 years ago

I am on windows x64 with nvidia gtx280 @ 270.61 (whql'd drivers)

#22 Updated by wespipes69 over 6 years ago

Darn. Same drivers here. Probably not the difference in card series...maybe win7x64 vs.XPx64?? I assume you are using the NTSC version as well.

I also even tried the 32bit Dolphin and no difference.

None the less, would you mind just reopening this so we can get to the bottom of this once and for all and acquire a fix for everyone? Thanks!

#23 Updated by godisgovernment over 6 years ago

  • Status changed from Fixed to Questionable

uhhh...fine, but there will be no progress unless it's reproducible. Maybe you should give up the ghost and install win7? :P

#24 Updated by wespipes69 over 6 years ago

Oh, I misread your comment - my brain added a "p" to your "x" there for some reason. Yes, I did give up xp in favor of win7 awhile ago and haven't looked back. :) So it's not an OS difference.

I hope someone else can chime in here. C'mon, I know a ton of people around here have this game, go make a custom vehicle and see if all 3 parts are rendered in races. And report back here please!

#25 Updated by wespipes69 over 6 years ago

To be 100% sure, you are using the NTSC version? The PAL displays correctly from everything I read/saw when this issue first popped up. I assume you are using ntsc version though since you could load my save properly...unless you converted it. And if you used a tool, let me know which one since I can never get saves I download to play right in other regions - even using the old GC file save convert 1.0.

#26 Updated by godisgovernment over 6 years ago

Yes, I used NTSC - the image has md5 of
81293462CF48C6A482C33E25C4097AC0, which is shown to be valid:
http://redump.org/disc/1555/

#27 Updated by wespipes69 over 6 years ago

Ok, don't hurt me....but after a fresh redump, it works fine! So it was the image afterall.

WEEEELLLL, at least we tracked it down and know now. And if it comes up again we can tell them what to go do....and where to stick their iso. :) Close please!

#28 Updated by godisgovernment over 6 years ago

  • Status changed from Questionable to Fixed

#29 Updated by multi-ultra almost 6 years ago

This problem has been confirmed to occur in r7719 and 3.0-159-diry. Therefore maybe this issue should be set to unfixed again, unless someone knows a solution?

#30 Updated by wespipes69 almost 6 years ago

Did you read the comments above. You have a bad dump. It only has and continues to work fine.

#31 Updated by igor0the0mii about 4 years ago

I DONT HAVE this issue. the ISO of the game is extracted from the coolrom.com website

Also available in: Atom PDF